Apache Syncope 1.0.0 before 1.0.9 and 1.1.0 before 1.1.7 allows remote administrators to…
Priority LOW 35CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Apache Syncope 1.0.0 before 1.0.9 and 1.1.0 before 1.1.7 allows remote administrators to execute arbitrary Java code via vectors related to Apache Commons JEXL expressions, "derived schema definition," "user / role templates," and "account links of resource mappings."
Why it matters now
EPSS 0.03311 88th percentileScored 2026-11-07
Fix Fixed org.apache.syncope:syncope (Maven): 1.0.9, 1.1.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.syncope:syncope (Maven) | 1.0.0 to before 1.0.9 | 1.0.9 | Patch available | GHSA-r2xf-w5pj-9pw8 |
| — | org.apache.syncope:syncope (Maven) | 1.1.0 to before 1.1.7 | 1.1.7 | Patch available | GHSA-r2xf-w5pj-9pw8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.syncope:syncope (Maven) Vendor— Affected 1.0.0 to before 1.0.9 Fixed in 1.0.9 Patch available GHSA-r2xf-w5pj-9pw8
- org.apache.syncope:syncope (Maven) Vendor— Affected 1.1.0 to before 1.1.7 Fixed in 1.1.7 Patch available GHSA-r2xf-w5pj-9pw8
Remediation
- Fix · GHSA-r2xf-w5pj-9pw8 org.apache.syncope:syncope (Maven) Fixed in 1.0.9 Advisory →
- Fix · GHSA-r2xf-w5pj-9pw8 org.apache.syncope:syncope (Maven) Fixed in 1.1.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-0111
- 2026-10-03 Alias added: GHSA-r2xf-w5pj-9pw8
References
More Apache Syncope vulnerabilities
- TI-2025-35632 Apache Syncope: Remote Code Execution by delegated administrators CVSS 3.1HIGH 7.2
- TI-2026-38503 Apache Syncope: Remote Code Execution via Scripted Connector CVSS 3.1CRITICAL 9.8
- TI-2026-45025 Apache Syncope: RCE via Groovy Sandbox bypass CVSS 3.1CRITICAL 9.8
- TI-2026-44406 Apache Syncope: User self-service privilege escalation CVSS 3.1CRITICAL 9.8
- TI-2026-41245 Apache Syncope: SQL injection vulnerability in Audit Events search CVSS 3.1CRITICAL 9.8
- TI-2026-38491 Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask CVSS 3.1CRITICAL 9.8
Sources
- CVE-2014-0111 · CVE Program
- CVE-2014-0111 · NVD
- FIRST EPSS
- GHSA-r2xf-w5pj-9pw8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences