QEMU, possibly before 2.0.0, allows local users to cause a denial of service…
Priority LOW 25CWE-369Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 8 fixed, 2 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-369.
Summary
QEMU, possibly before 2.0.0, allows local users to cause a denial of service (divide-by-zero error and crash) via a zero value in the (1) tracks field to the seek_to_sector function in block/parallels.c or (2) extent_size field in the bochs function in block/bochs.c.
Why it matters now
EPSS 0.00382 32nd percentileScored 2026-11-07
Fix Partial Red Hat: 5 advisoriesRed Hat: 8 fixed, 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
Red Hat 5 advisories
- RHSA-2014:0674 Released 2014-06-09 · Red Hat rating Moderaterhev-hypervisor6 3.4.0 security, bug fix, and enhancement update
- RHEV Hypervisor for RHEL-6 rhev-hypervisor6-6.5-20140603.2.el6ev
- RHSA-2014:0434 Released 2014-04-24 · Red Hat rating Moderateqemu-kvm-rhev security update
- Red Hat Enterprise Linux OpenStack Platform 4.0 qemu-img-rhev-2:0.12.1.2-2.415.el6_5.8, qemu-kvm-rhev-2:0.12.1.2-2.415.el6_5.8, qemu-kvm-rhev-tools-2:0.12.1.2-2.415.el6_5.8
- RHSA-2014:0435 Released 2014-04-24 · Red Hat rating Moderateqemu-kvm-rhev security update
- Red Hat Enterprise Linux OpenStack Platform 3.0 qemu-img-rhev-2:0.12.1.2-2.415.el6_5.8, qemu-kvm-rhev-2:0.12.1.2-2.415.el6_5.8, qemu-kvm-rhev-tools-2:0.12.1.2-2.415.el6_5.8
Show 2 more Red Hat advisories
- RHSA-2014:0420 Released 2014-04-22 · Red Hat rating Moderateqemu-kvm security update
- Red Hat Enterprise Linux Desktop (v. 6) qemu-guest-agent-2:0.12.1.2-2.415.el6_5.8, qemu-img-2:0.12.1.2-2.415.el6_5.8, qemu-kvm-2:0.12.1.2-2.415.el6_5.8 +1
- Red Hat Enterprise Linux HPC Node (v. 6) qemu-guest-agent-2:0.12.1.2-2.415.el6_5.8, qemu-img-2:0.12.1.2-2.415.el6_5.8, qemu-kvm-2:0.12.1.2-2.415.el6_5.8 +1
- Red Hat Enterprise Linux Server (v. 6) qemu-guest-agent-2:0.12.1.2-2.415.el6_5.8, qemu-img-2:0.12.1.2-2.415.el6_5.8, qemu-kvm-2:0.12.1.2-2.415.el6_5.8 +1
- Red Hat Enterprise Linux Workstation (v. 6) qemu-guest-agent-2:0.12.1.2-2.415.el6_5.8, qemu-img-2:0.12.1.2-2.415.el6_5.8, qemu-kvm-2:0.12.1.2-2.415.el6_5.8 +1
- RHSA-2014:0421 Released 2014-04-22 · Red Hat rating Moderateqemu-kvm-rhev security update
- RHEV Agents (vdsm) qemu-img-rhev-2:0.12.1.2-2.415.el6_5.8, qemu-kvm-rhev-2:0.12.1.2-2.415.el6_5.8, qemu-kvm-rhev-tools-2:0.12.1.2-2.415.el6_5.8
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux OpenStack Platform 5 (Icehouse) | Affected | No fix yet |
| RHEV Agents (vdsm) | Fixed | RHSA-2014:0421 |
| RHEV Hypervisor for RHEL-6 | Fixed | RHSA-2014:0674 |
| Red Hat Enterprise Linux Desktop (v. 6) | Fixed | RHSA-2014:0420 |
| Red Hat Enterprise Linux HPC Node (v. 6) | Fixed | RHSA-2014:0420 |
| Red Hat Enterprise Linux OpenStack Platform 3.0 | Fixed | RHSA-2014:0435 |
| Red Hat Enterprise Linux OpenStack Platform 4.0 | Fixed | RHSA-2014:0434 |
| Red Hat Enterprise Linux Server (v. 6) | Fixed | RHSA-2014:0420 |
| Red Hat Enterprise Linux Workstation (v. 6) | Fixed | RHSA-2014:0420 |
Not affected: 1 product
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2014-0142
- 2026-10-03 Alias added: GHSA-cgcg-9vhg-7fq9
References
More Qemu vulnerabilities
- TI-2024-16148 QEMU before 8.2.0 has an integer underflow, and resultant buffer overflow, via a TI… CVSS 3.1HIGH 8.8
- TI-2022-02736 Uncontrolled resource consumption in QEMU CVSS 3.1HIGH 7.8
- TI-2023-02681 Qemu: 9pfs: improper access control on special files CVSS 3.1HIGH 7.1
- TI-2019-09678 The QMP migrate command in QEMU version 4.0.0 and earlier is vulnerable to OS command… CVSS 3.0CRITICAL 9.8
- TI-2024-03326 Qemu-kvm: net: assertion failure in update_sctp_checksum() CVSS 3.1MEDIUM 5.5
- TI-2023-22631 QEMU through 8.0.0 could trigger a division by zero in scsi_disk_reset in… CVSS 3.1MEDIUM 5.5
Sources
- CVE-2014-0142 · CVE Program
- CVE-2014-0142 · NVD
- FIRST EPSS
- GHSA-cgcg-9vhg-7fq9 · GitHub Advisory Database · CC BY 4.0
- CVE-2014-0142 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences