Multiple buffer overflows in QEMU before 1.7.2 and 2.x before 2.0.0, allow local users to…
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 8 fixed, 2 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-119 and the CVSS impact.
Summary
Multiple buffer overflows in QEMU before 1.7.2 and 2.x before 2.0.0, allow local users to cause a denial of service (crash) or possibly execute arbitrary code via a large (1) L1 table in the qcow2_snapshot_load_tmp in the QCOW 2 block driver (block/qcow2-snapshot.c) or (2) uncompressed chunk, (3) chunk length, or (4) number of sectors in the DMG block driver (block/dmg.c).
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:* | up to 1.7.1 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:2.0.0:rc0:*:*:*:*:*:* | 2.0.0 rc0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:2.0.0:rc1:*:*:*:*:*:* | 2.0.0 rc1 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:2.0.0:rc2:*:*:*:*:*:* | 2.0.0 rc2 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:2.0.0:rc3:*:*:*:*:*:* | 2.0.0 rc3 | Vulnerable | QEMU |
- cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:* Versions up to 1.7.1 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:2.0.0:rc0:*:*:*:*:*:* Versions 2.0.0 rc0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:2.0.0:rc1:*:*:*:*:*:* Versions 2.0.0 rc1 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:2.0.0:rc2:*:*:*:*:*:* Versions 2.0.0 rc2 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:2.0.0:rc3:*:*:*:*:*:* Versions 2.0.0 rc3 Vulnerable ·QEMU
Remediation
Red Hat 5 advisories
- RHSA-2014:0674 Released 2014-06-09 · Red Hat rating Moderaterhev-hypervisor6 3.4.0 security, bug fix, and enhancement update
- RHEV Hypervisor for RHEL-6 rhev-hypervisor6-6.5-20140603.2.el6ev
- RHSA-2014:0434 Released 2014-04-24 · Red Hat rating Moderateqemu-kvm-rhev security update
- Red Hat Enterprise Linux OpenStack Platform 4.0 qemu-img-rhev-2:0.12.1.2-2.415.el6_5.8, qemu-kvm-rhev-2:0.12.1.2-2.415.el6_5.8, qemu-kvm-rhev-tools-2:0.12.1.2-2.415.el6_5.8
- RHSA-2014:0435 Released 2014-04-24 · Red Hat rating Moderateqemu-kvm-rhev security update
- Red Hat Enterprise Linux OpenStack Platform 3.0 qemu-img-rhev-2:0.12.1.2-2.415.el6_5.8, qemu-kvm-rhev-2:0.12.1.2-2.415.el6_5.8, qemu-kvm-rhev-tools-2:0.12.1.2-2.415.el6_5.8
Show 2 more Red Hat advisories
- RHSA-2014:0420 Released 2014-04-22 · Red Hat rating Moderateqemu-kvm security update
- Red Hat Enterprise Linux Desktop (v. 6) qemu-guest-agent-2:0.12.1.2-2.415.el6_5.8, qemu-img-2:0.12.1.2-2.415.el6_5.8, qemu-kvm-2:0.12.1.2-2.415.el6_5.8 +1
- Red Hat Enterprise Linux HPC Node (v. 6) qemu-guest-agent-2:0.12.1.2-2.415.el6_5.8, qemu-img-2:0.12.1.2-2.415.el6_5.8, qemu-kvm-2:0.12.1.2-2.415.el6_5.8 +1
- Red Hat Enterprise Linux Server (v. 6) qemu-guest-agent-2:0.12.1.2-2.415.el6_5.8, qemu-img-2:0.12.1.2-2.415.el6_5.8, qemu-kvm-2:0.12.1.2-2.415.el6_5.8 +1
- Red Hat Enterprise Linux Workstation (v. 6) qemu-guest-agent-2:0.12.1.2-2.415.el6_5.8, qemu-img-2:0.12.1.2-2.415.el6_5.8, qemu-kvm-2:0.12.1.2-2.415.el6_5.8 +1
- RHSA-2014:0421 Released 2014-04-22 · Red Hat rating Moderateqemu-kvm-rhev security update
- RHEV Agents (vdsm) qemu-img-rhev-2:0.12.1.2-2.415.el6_5.8, qemu-kvm-rhev-2:0.12.1.2-2.415.el6_5.8, qemu-kvm-rhev-tools-2:0.12.1.2-2.415.el6_5.8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux OpenStack Platform 5 (Icehouse) | Affected | No fix yet |
| RHEV Agents (vdsm) | Fixed | RHSA-2014:0421 |
| RHEV Hypervisor for RHEL-6 | Fixed | RHSA-2014:0674 |
| Red Hat Enterprise Linux Desktop (v. 6) | Fixed | RHSA-2014:0420 |
| Red Hat Enterprise Linux HPC Node (v. 6) | Fixed | RHSA-2014:0420 |
| Red Hat Enterprise Linux OpenStack Platform 3.0 | Fixed | RHSA-2014:0435 |
| Red Hat Enterprise Linux OpenStack Platform 4.0 | Fixed | RHSA-2014:0434 |
| Red Hat Enterprise Linux Server (v. 6) | Fixed | RHSA-2014:0420 |
| Red Hat Enterprise Linux Workstation (v. 6) | Fixed | RHSA-2014:0420 |
Not affected: 1 product
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2014-0145
- 2026-10-03 Alias added: GHSA-cc9p-3fx3-m352
References
Advisory 5
More Qemu vulnerabilities
- TI-2024-16148 QEMU before 8.2.0 has an integer underflow, and resultant buffer overflow, via a TI… CVSS 3.1HIGH 8.8
- TI-2022-02736 Uncontrolled resource consumption in QEMU CVSS 3.1HIGH 7.8
- TI-2023-02681 Qemu: 9pfs: improper access control on special files CVSS 3.1HIGH 7.1
- TI-2019-09678 The QMP migrate command in QEMU version 4.0.0 and earlier is vulnerable to OS command… CVSS 3.0CRITICAL 9.8
- TI-2024-03326 Qemu-kvm: net: assertion failure in update_sctp_checksum() CVSS 3.1MEDIUM 5.5
- TI-2023-22631 QEMU through 8.0.0 could trigger a division by zero in scsi_disk_reset in… CVSS 3.1MEDIUM 5.5
Sources
- CVE-2014-0145 · CVE Program
- CVE-2014-0145 · NVD
- FIRST EPSS
- GHSA-cc9p-3fx3-m352 · GitHub Advisory Database · CC BY 4.0
- CVE-2014-0145 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences