enrol/index.php in Moodle 2.6.x before 2.6.3 does not check for the…
Priority LOW 24CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
enrol/index.php in Moodle 2.6.x before 2.6.3 does not check for the moodle/course:viewhiddencourses capability before listing hidden courses, which allows remote attackers to obtain sensitive name and summary information about these courses by leveraging the guest role and visiting a crafted URL.
Why it matters now
EPSS 0.01871 79th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.6.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 2.6.0 to before 2.6.3 | 2.6.3 | Patch available | GHSA-c3vx-v4x8-x894 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 2.6.0 to before 2.6.3 Fixed in 2.6.3 Patch available GHSA-c3vx-v4x8-x894
Remediation
- Fix · GHSA-c3vx-v4x8-x894 moodle/moodle (Packagist) Fixed in 2.6.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2014-0217
- 2026-10-03 Alias added: GHSA-c3vx-v4x8-x894
References
Advisory 2
Other 5
- [oss-security] 20140519 Moodle security notifications public
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-45126
- https://github.com/moodle/moodle/commit/eaea796e70f6630494d3772684604ab6e907f4ac
- https://github.com/moodle/moodle/commit/fcf199e7a13e453bfe3855c6946e8357fcbdef92
- https://github.com/moodle/moodle
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2014-0217 · CVE Program
- CVE-2014-0217 · NVD
- FIRST EPSS
- GHSA-c3vx-v4x8-x894 · GitHub Advisory Database · CC BY 4.0
- CVE-2014-0217 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences