Apache Syncope 1.1.x before 1.1.8 uses weak random values to generate passwords, which…
Priority LOW 32CWE-310Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
Apache Syncope 1.1.x before 1.1.8 uses weak random values to generate passwords, which makes it easier for remote attackers to guess the password via a brute force attack.
Why it matters now
EPSS 0.06023 93rd percentileScored 2026-11-07
Fix Fixed org.apache.syncope:syncope (Maven): 1.1.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.syncope:syncope (Maven) | 1.1.0 to before 1.1.8 | 1.1.8 | Patch available | GHSA-4c72-mrhf-23cg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.syncope:syncope (Maven) Vendor— Affected 1.1.0 to before 1.1.8 Fixed in 1.1.8 Patch available GHSA-4c72-mrhf-23cg
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:syncope:1.1.0:*:*:*:*:*:*:* | 1.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:syncope:1.1.1:*:*:*:*:*:*:* | 1.1.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:syncope:1.1.2:*:*:*:*:*:*:* | 1.1.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:syncope:1.1.3:*:*:*:*:*:*:* | 1.1.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:syncope:1.1.4:*:*:*:*:*:*:* | 1.1.4 | Vulnerable | Apache |
| cpe:2.3:a:apache:syncope:1.1.5:*:*:*:*:*:*:* | 1.1.5 | Vulnerable | Apache |
| cpe:2.3:a:apache:syncope:1.1.6:*:*:*:*:*:*:* | 1.1.6 | Vulnerable | Apache |
| cpe:2.3:a:apache:syncope:1.1.7:*:*:*:*:*:*:* | 1.1.7 | Vulnerable | Apache |
- cpe:2.3:a:apache:syncope:1.1.0:*:*:*:*:*:*:* Versions 1.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:syncope:1.1.1:*:*:*:*:*:*:* Versions 1.1.1 Vulnerable ·Apache
- cpe:2.3:a:apache:syncope:1.1.2:*:*:*:*:*:*:* Versions 1.1.2 Vulnerable ·Apache
- cpe:2.3:a:apache:syncope:1.1.3:*:*:*:*:*:*:* Versions 1.1.3 Vulnerable ·Apache
- cpe:2.3:a:apache:syncope:1.1.4:*:*:*:*:*:*:* Versions 1.1.4 Vulnerable ·Apache
- cpe:2.3:a:apache:syncope:1.1.5:*:*:*:*:*:*:* Versions 1.1.5 Vulnerable ·Apache
- cpe:2.3:a:apache:syncope:1.1.6:*:*:*:*:*:*:* Versions 1.1.6 Vulnerable ·Apache
- cpe:2.3:a:apache:syncope:1.1.7:*:*:*:*:*:*:* Versions 1.1.7 Vulnerable ·Apache
Remediation
- Fix · GHSA-4c72-mrhf-23cg org.apache.syncope:syncope (Maven) Fixed in 1.1.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-3503
- 2026-10-03 Alias added: GHSA-4c72-mrhf-23cg
References
Other 6
- http://packetstormsecurity.com/files/127375/Apache-Syncope-Insecure-Password-Generation.html
- https://github.com/apache/syncope/commit/8e0045925a387ee211832c7e0709dd418cda1ad3
- https://syncope.apache.org/security.html#cve-2014-3503-insecure-random-implementations-used-to-generate-p
- https://web.archive.org/web/20140728093808/http://www.securityfocus.com/bid/68431
- https://web.archive.org/web/20201207014021/http://www.securityfocus.com/archive/1/532669/100/0/threaded
- http://svn.apache.org/viewvc?view=revision&revision=r1596537
More Apache Syncope vulnerabilities
- TI-2025-35632 Apache Syncope: Remote Code Execution by delegated administrators CVSS 3.1HIGH 7.2
- TI-2026-38503 Apache Syncope: Remote Code Execution via Scripted Connector CVSS 3.1CRITICAL 9.8
- TI-2026-45025 Apache Syncope: RCE via Groovy Sandbox bypass CVSS 3.1CRITICAL 9.8
- TI-2026-44406 Apache Syncope: User self-service privilege escalation CVSS 3.1CRITICAL 9.8
- TI-2026-41245 Apache Syncope: SQL injection vulnerability in Audit Events search CVSS 3.1CRITICAL 9.8
- TI-2026-38491 Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask CVSS 3.1CRITICAL 9.8
Sources
- CVE-2014-3503 · CVE Program
- CVE-2014-3503 · NVD
- FIRST EPSS
- GHSA-4c72-mrhf-23cg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences