Read the docs
TI-2014-02872 Aliases CVE-2014-3547GHSA-hwjv-mc78-cccj

Multiple cross-site scripting (XSS) vulnerabilities in badges/renderer.php in Moodle…

Priority LOW 22CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · Partial · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Multiple cross-site scripting (XSS) vulnerabilities in badges/renderer.php in Moodle 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allow remote attackers to inject arbitrary web script or HTML via an external badge.

Why it matters now

EPSS 0.01187 68th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.5.7, 2.6.4, 2.7.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—moodle/moodle (Packagist)2.5.0 to before 2.5.72.5.7Patch availableGHSA-hwjv-mc78-cccj
—moodle/moodle (Packagist)2.6.0 to before 2.6.42.6.4Patch availableGHSA-hwjv-mc78-cccj
—moodle/moodle (Packagist)2.7.0 to before 2.7.12.7.1Patch availableGHSA-hwjv-mc78-cccj
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 2.5.0 to before 2.5.7 Fixed in 2.5.7 Patch available GHSA-hwjv-mc78-cccj
  • moodle/moodle (Packagist) Vendor— Affected 2.6.0 to before 2.6.4 Fixed in 2.6.4 Patch available GHSA-hwjv-mc78-cccj
  • moodle/moodle (Packagist) Vendor— Affected 2.7.0 to before 2.7.1 Fixed in 2.7.1 Patch available GHSA-hwjv-mc78-cccj

CPE configurations NVD · 12

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:2.5.0:*:*:*:*:*:*:*2.5.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.1:*:*:*:*:*:*:*2.5.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.2:*:*:*:*:*:*:*2.5.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.3:*:*:*:*:*:*:*2.5.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.4:*:*:*:*:*:*:*2.5.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.5:*:*:*:*:*:*:*2.5.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.6:*:*:*:*:*:*:*2.5.6VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.0:*:*:*:*:*:*:*2.6.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.1:*:*:*:*:*:*:*2.6.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.2:*:*:*:*:*:*:*2.6.2VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.1:*:*:*:*:*:*:* Versions 2.5.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.2:*:*:*:*:*:*:* Versions 2.5.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.3:*:*:*:*:*:*:* Versions 2.5.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.4:*:*:*:*:*:*:* Versions 2.5.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.5:*:*:*:*:*:*:* Versions 2.5.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.6:*:*:*:*:*:*:* Versions 2.5.6 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.0:*:*:*:*:*:*:* Versions 2.6.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.1:*:*:*:*:*:*:* Versions 2.6.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.2:*:*:*:*:*:*:* Versions 2.6.2 Vulnerable ·Moodle
Show 2 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:2.6.3:*:*:*:*:*:*:*2.6.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:*2.7.0VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:2.6.3:*:*:*:*:*:*:* Versions 2.6.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-hwjv-mc78-cccj moodle/moodle (Packagist) Fixed in 2.5.7 Advisory →
  • Fix · GHSA-hwjv-mc78-cccj moodle/moodle (Packagist) Fixed in 2.6.4 Advisory →
  • Fix · GHSA-hwjv-mc78-cccj moodle/moodle (Packagist) Fixed in 2.7.1 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2014-3547
  2. 2026-10-03 Alias added: GHSA-hwjv-mc78-cccj

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources