The YARN NodeManager daemon in Apache Hadoop 0.23.0 through 0.23.11 and 2.x before 2.5.2…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-59 and the CVSS impact.
Summary
The YARN NodeManager daemon in Apache Hadoop 0.23.0 through 0.23.11 and 2.x before 2.5.2, when using Kerberos authentication, allows remote cluster users to change the permissions of certain files to world-readable via a symlink attack in a public tar archive, which is not properly handled during localization, related to distributed cache.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.hadoop:hadoop-client (Maven) | 0.23.0 to before 1.0.1 | 1.0.1 | Patch available | GHSA-jpmf-8cj2-595g |
| — | org.apache.hadoop:hadoop-client (Maven) | 2.0.0 to before 2.5.2 | 2.5.2 | Patch available | GHSA-jpmf-8cj2-595g |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.hadoop:hadoop-client (Maven) Vendor— Affected 0.23.0 to before 1.0.1 Fixed in 1.0.1 Patch available GHSA-jpmf-8cj2-595g
- org.apache.hadoop:hadoop-client (Maven) Vendor— Affected 2.0.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-jpmf-8cj2-595g
CPE configurations NVD · 26
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:hadoop:0.23.0:*:*:*:*:*:*:* | 0.23.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:0.23.1:*:*:*:*:*:*:* | 0.23.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:0.23.3:*:*:*:*:*:*:* | 0.23.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:0.23.4:*:*:*:*:*:*:* | 0.23.4 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:0.23.5:*:*:*:*:*:*:* | 0.23.5 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:0.23.6:*:*:*:*:*:*:* | 0.23.6 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:0.23.7:*:*:*:*:*:*:* | 0.23.7 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:0.23.8:*:*:*:*:*:*:* | 0.23.8 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:0.23.9:*:*:*:*:*:*:* | 0.23.9 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:0.23.10:*:*:*:*:*:*:* | 0.23.10 | Vulnerable | Apache |
- cpe:2.3:a:apache:hadoop:0.23.0:*:*:*:*:*:*:* Versions 0.23.0 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:0.23.1:*:*:*:*:*:*:* Versions 0.23.1 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:0.23.3:*:*:*:*:*:*:* Versions 0.23.3 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:0.23.4:*:*:*:*:*:*:* Versions 0.23.4 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:0.23.5:*:*:*:*:*:*:* Versions 0.23.5 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:0.23.6:*:*:*:*:*:*:* Versions 0.23.6 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:0.23.7:*:*:*:*:*:*:* Versions 0.23.7 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:0.23.8:*:*:*:*:*:*:* Versions 0.23.8 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:0.23.9:*:*:*:*:*:*:* Versions 0.23.9 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:0.23.10:*:*:*:*:*:*:* Versions 0.23.10 Vulnerable ·Apache
Show 16 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:hadoop:0.23.11:*:*:*:*:*:*:* | 0.23.11 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.0:alpha:*:*:*:*:*:* | 2.0.0 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.1:alpha:*:*:*:*:*:* | 2.0.1 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.2:alpha:*:*:*:*:*:* | 2.0.2 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.3:alpha:*:*:*:*:*:* | 2.0.3 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.4:alpha:*:*:*:*:*:* | 2.0.4 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.5:alpha:*:*:*:*:*:* | 2.0.5 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.6:alpha:*:*:*:*:*:* | 2.0.6 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.1.0:beta:*:*:*:*:*:* | 2.1.0 beta | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.1.1:beta:*:*:*:*:*:* | 2.1.1 beta | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.2.0:*:*:*:*:*:*:* | 2.2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.3.0:*:*:*:*:*:*:* | 2.3.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.4.0:*:*:*:*:*:*:* | 2.4.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.4.1:*:*:*:*:*:*:* | 2.4.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.5.0:*:*:*:*:*:*:* | 2.5.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.5.1:*:*:*:*:*:*:* | 2.5.1 | Vulnerable | Apache |
- cpe:2.3:a:apache:hadoop:0.23.11:*:*:*:*:*:*:* Versions 0.23.11 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.0:alpha:*:*:*:*:*:* Versions 2.0.0 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.1:alpha:*:*:*:*:*:* Versions 2.0.1 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.2:alpha:*:*:*:*:*:* Versions 2.0.2 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.3:alpha:*:*:*:*:*:* Versions 2.0.3 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.4:alpha:*:*:*:*:*:* Versions 2.0.4 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.5:alpha:*:*:*:*:*:* Versions 2.0.5 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.6:alpha:*:*:*:*:*:* Versions 2.0.6 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.1.0:beta:*:*:*:*:*:* Versions 2.1.0 beta Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.1.1:beta:*:*:*:*:*:* Versions 2.1.1 beta Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.3.0:*:*:*:*:*:*:* Versions 2.3.0 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.4.0:*:*:*:*:*:*:* Versions 2.4.0 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.4.1:*:*:*:*:*:*:* Versions 2.4.1 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.5.1:*:*:*:*:*:*:* Versions 2.5.1 Vulnerable ·Apache
Remediation
- Fix · GHSA-jpmf-8cj2-595g org.apache.hadoop:hadoop-client (Maven) Fixed in 1.0.1 Advisory →
- Fix · GHSA-jpmf-8cj2-595g org.apache.hadoop:hadoop-client (Maven) Fixed in 2.5.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Virtualization 3 | Affected | — |
Timeline
- 2026-10-02 Threatist record created from CVE-2014-3627
- 2026-10-03 Alias added: GHSA-jpmf-8cj2-595g
References
More Apache Hadoop vulnerabilities
- TI-2019-12818 Connect2id Nimbus JOSE+JWT before v7.9 can throw various uncaught exceptions while… CVSS 3.1CRITICAL 9.8
- TI-2022-09898 Arbitrary file write in FileUtil#unpackEntries on Windows CVSS 3.1CRITICAL 9.8
- TI-2022-08881 Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar CVSS 3.1CRITICAL 9.8
- TI-2021-15353 Heap buffer overflow in libhdfs native library CVSS 3.1CRITICAL 9.8
- TI-2018-05786 Path traversal in Apache Hadoop CVSS 3.0HIGH 8.8
- TI-2017-11489 Information disclosure in Apache Hadoop CVSS 3.0CRITICAL 9.8
Sources
- CVE-2014-3627 · CVE Program
- CVE-2014-3627 · NVD
- FIRST EPSS
- GHSA-jpmf-8cj2-595g · GitHub Advisory Database · CC BY 4.0
- CVE-2014-3627 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences