Read the docs
TI-2014-05993 Aliases CVE-2014-7191GHSA-jjv7-qpx3-h62q

The qs module before 1.0.0 in Node.js does not call the compact function for array data…

Priority LOW 34CWE-399Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · Partial
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-399 and the CVSS impact.

Summary

The qs module before 1.0.0 in Node.js does not call the compact function for array data, which allows remote attackers to cause a denial of service (memory consumption) by using a large index value to create a sparse array.

Why it matters now

EPSS 0.08309 94th percentileScored 2026-11-07
Fix Fixed qs (npm): 1.0.0Red Hat: 1 advisory

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—qs (npm)before 1.0.01.0.0Patch availableGHSA-jjv7-qpx3-h62q
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • qs (npm) Vendor— Affected before 1.0.0 Fixed in 1.0.0 Patch available GHSA-jjv7-qpx3-h62q

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:*up to 0.10.18VulnerableNodeJS
  • cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:* Versions up to 0.10.18 Vulnerable ·NodeJS

Remediation

  • Fix · GHSA-jjv7-qpx3-h62q qs (npm) Fixed in 1.0.0 Advisory →

Red Hat 1 advisory

  • RHSA-2016:1380 Released 2016-07-05 · Red Hat rating Moderate
    nodejs010-node-gyp and nodejs010-nodejs-qs security and bug fix update
    • Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 6) nodejs010-node-gyp-3.2.0-3.el6, nodejs010-nodejs-qs-0.6.5-5.el6
    • Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) nodejs010-node-gyp-3.2.0-3.el7, nodejs010-nodejs-qs-0.6.5-5.el7
    • Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 6.6) nodejs010-node-gyp-3.2.0-3.el6, nodejs010-nodejs-qs-0.6.5-5.el6
    • Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 6.7) nodejs010-node-gyp-3.2.0-3.el6, nodejs010-nodejs-qs-0.6.5-5.el6
    • Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.1) nodejs010-node-gyp-3.2.0-3.el7, nodejs010-nodejs-qs-0.6.5-5.el7
    • Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.2) nodejs010-node-gyp-3.2.0-3.el7, nodejs010-nodejs-qs-0.6.5-5.el7
    • Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 6) nodejs010-node-gyp-3.2.0-3.el6, nodejs010-nodejs-qs-0.6.5-5.el6
    • Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) nodejs010-node-gyp-3.2.0-3.el7, nodejs010-nodejs-qs-0.6.5-5.el7

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 6)Fixed RHSA-2016:1380
Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7)Fixed RHSA-2016:1380
Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 6.6)Fixed RHSA-2016:1380
Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 6.7)Fixed RHSA-2016:1380
Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.1)Fixed RHSA-2016:1380
Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.2)Fixed RHSA-2016:1380
Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 6)Fixed RHSA-2016:1380
Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7)Fixed RHSA-2016:1380

Timeline

  1. 2026-10-02 Threatist record created from CVE-2014-7191
  2. 2026-10-03 Alias added: GHSA-jjv7-qpx3-h62q

References

  • TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2016-01993 The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other… CVSS 3.1HIGH 7.5
  • TI-2024-03325 Command injection vulnerability in programing languages on Microsoft Windows operating system. CVSS 3.1CRITICAL 9.8
  • TI-2022-03472 X.509 Email Address Variable Length Buffer Overflow CVSS 3.1HIGH 7.5
  • TI-2022-03315 X.509 Email Address 4-byte Buffer Overflow CVSS 3.1HIGH 7.5
See all 186 →

Sources