webservice/upload.php in Moodle 2.6.x before 2.6.6 and 2.7.x before 2.7.3 does not ensure…
Priority LOW 14CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
webservice/upload.php in Moodle 2.6.x before 2.6.6 and 2.7.x before 2.7.3 does not ensure that a file upload is for a private or draft area, which allows remote authenticated users to upload files containing JavaScript, and consequently conduct cross-site scripting (XSS) attacks, by specifying the profile-picture area.
Why it matters now
EPSS 0.01433 73rd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.6.6, 2.7.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 2.6.0 to before 2.6.6 | 2.6.6 | Patch available | GHSA-vrf6-q7qj-69v5 |
| — | moodle/moodle (Packagist) | 2.7.0 to before 2.7.3 | 2.7.3 | Patch available | GHSA-vrf6-q7qj-69v5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 2.6.0 to before 2.6.6 Fixed in 2.6.6 Patch available GHSA-vrf6-q7qj-69v5
- moodle/moodle (Packagist) Vendor— Affected 2.7.0 to before 2.7.3 Fixed in 2.7.3 Patch available GHSA-vrf6-q7qj-69v5
CPE configurations NVD · 19
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | up to 2.4.11 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.0:*:*:*:*:*:*:* | 2.5.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.1:*:*:*:*:*:*:* | 2.5.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.2:*:*:*:*:*:*:* | 2.5.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.3:*:*:*:*:*:*:* | 2.5.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.4:*:*:*:*:*:*:* | 2.5.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.5:*:*:*:*:*:*:* | 2.5.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.6:*:*:*:*:*:*:* | 2.5.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.7:*:*:*:*:*:*:* | 2.5.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.8:*:*:*:*:*:*:* | 2.5.8 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions up to 2.4.11 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.1:*:*:*:*:*:*:* Versions 2.5.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.2:*:*:*:*:*:*:* Versions 2.5.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.3:*:*:*:*:*:*:* Versions 2.5.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.4:*:*:*:*:*:*:* Versions 2.5.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.5:*:*:*:*:*:*:* Versions 2.5.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.6:*:*:*:*:*:*:* Versions 2.5.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.7:*:*:*:*:*:*:* Versions 2.5.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.8:*:*:*:*:*:*:* Versions 2.5.8 Vulnerable ·Moodle
Show 9 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.6.0:*:*:*:*:*:*:* | 2.6.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.1:*:*:*:*:*:*:* | 2.6.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.2:*:*:*:*:*:*:* | 2.6.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.3:*:*:*:*:*:*:* | 2.6.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.4:*:*:*:*:*:*:* | 2.6.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.5:*:*:*:*:*:*:* | 2.6.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:* | 2.7.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:* | 2.7.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:* | 2.7.2 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.6.0:*:*:*:*:*:*:* Versions 2.6.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.1:*:*:*:*:*:*:* Versions 2.6.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.2:*:*:*:*:*:*:* Versions 2.6.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.3:*:*:*:*:*:*:* Versions 2.6.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.4:*:*:*:*:*:*:* Versions 2.6.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.5:*:*:*:*:*:*:* Versions 2.6.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:* Versions 2.7.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:* Versions 2.7.2 Vulnerable ·Moodle
Remediation
- Fix · GHSA-vrf6-q7qj-69v5 moodle/moodle (Packagist) Fixed in 2.6.6 Advisory →
- Fix · GHSA-vrf6-q7qj-69v5 moodle/moodle (Packagist) Fixed in 2.7.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2014-7835
- 2026-10-03 Alias added: GHSA-vrf6-q7qj-69v5
References
Other 8
- [oss-security] 20141117 Moodle security issues are now public
- https://moodle.org/mod/forum/discuss.php?d=275161
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-47868
- https://github.com/moodle/moodle/commit/2f87351d5480f562d6811cdf3bea032612e0325e
- https://github.com/moodle/moodle/commit/76ae1f6068f63149acc2d8c362af94067f4a227d
- https://github.com/moodle/moodle/commit/ea1fbc00285514242d620ea017e187eb139deedb
- https://github.com/moodle/moodle
- https://web.archive.org/web/20150914064838/http://www.securitytracker.com/id/1031215
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2014-7835 · CVE Program
- CVE-2014-7835 · NVD
- FIRST EPSS
- GHSA-vrf6-q7qj-69v5 · GitHub Advisory Database · CC BY 4.0
- CVE-2014-7835 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences