The LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and…
Priority LOW 27CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
The LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not properly restrict the parameters used in a return URL, which allows remote attackers to trigger the generation of arbitrary messages via a modified URL, related to mod/lti/locallib.php and mod/lti/return.php.
Why it matters now
EPSS 0.02118 81st percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.5.9, 2.6.6, 2.7.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | before 2.5.9 | 2.5.9 | Patch available | GHSA-c87j-9rrq-h3j8 |
| — | moodle/moodle (Packagist) | 2.6.0 to before 2.6.6 | 2.6.6 | Patch available | GHSA-c87j-9rrq-h3j8 |
| — | moodle/moodle (Packagist) | 2.7.0 to before 2.7.3 | 2.7.3 | Patch available | GHSA-c87j-9rrq-h3j8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected before 2.5.9 Fixed in 2.5.9 Patch available GHSA-c87j-9rrq-h3j8
- moodle/moodle (Packagist) Vendor— Affected 2.6.0 to before 2.6.6 Fixed in 2.6.6 Patch available GHSA-c87j-9rrq-h3j8
- moodle/moodle (Packagist) Vendor— Affected 2.7.0 to before 2.7.3 Fixed in 2.7.3 Patch available GHSA-c87j-9rrq-h3j8
CPE configurations NVD · 19
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | up to 2.4.11 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.0:*:*:*:*:*:*:* | 2.5.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.1:*:*:*:*:*:*:* | 2.5.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.2:*:*:*:*:*:*:* | 2.5.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.3:*:*:*:*:*:*:* | 2.5.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.4:*:*:*:*:*:*:* | 2.5.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.5:*:*:*:*:*:*:* | 2.5.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.6:*:*:*:*:*:*:* | 2.5.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.7:*:*:*:*:*:*:* | 2.5.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.8:*:*:*:*:*:*:* | 2.5.8 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions up to 2.4.11 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.1:*:*:*:*:*:*:* Versions 2.5.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.2:*:*:*:*:*:*:* Versions 2.5.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.3:*:*:*:*:*:*:* Versions 2.5.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.4:*:*:*:*:*:*:* Versions 2.5.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.5:*:*:*:*:*:*:* Versions 2.5.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.6:*:*:*:*:*:*:* Versions 2.5.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.7:*:*:*:*:*:*:* Versions 2.5.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.8:*:*:*:*:*:*:* Versions 2.5.8 Vulnerable ·Moodle
Show 9 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.6.0:*:*:*:*:*:*:* | 2.6.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.1:*:*:*:*:*:*:* | 2.6.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.2:*:*:*:*:*:*:* | 2.6.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.3:*:*:*:*:*:*:* | 2.6.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.4:*:*:*:*:*:*:* | 2.6.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.5:*:*:*:*:*:*:* | 2.6.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:* | 2.7.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:* | 2.7.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:* | 2.7.2 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.6.0:*:*:*:*:*:*:* Versions 2.6.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.1:*:*:*:*:*:*:* Versions 2.6.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.2:*:*:*:*:*:*:* Versions 2.6.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.3:*:*:*:*:*:*:* Versions 2.6.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.4:*:*:*:*:*:*:* Versions 2.6.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.5:*:*:*:*:*:*:* Versions 2.6.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:* Versions 2.7.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:* Versions 2.7.2 Vulnerable ·Moodle
Remediation
- Fix · GHSA-c87j-9rrq-h3j8 moodle/moodle (Packagist) Fixed in 2.5.9 Advisory →
- Fix · GHSA-c87j-9rrq-h3j8 moodle/moodle (Packagist) Fixed in 2.6.6 Advisory →
- Fix · GHSA-c87j-9rrq-h3j8 moodle/moodle (Packagist) Fixed in 2.7.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-9060
- 2026-10-03 Alias added: GHSA-c87j-9rrq-h3j8
References
Advisory 2
Other 8
- [oss-security] 20141117 Moodle security issues are now public
- https://moodle.org/mod/forum/discuss.php?d=275165
- https://github.com/moodle/moodle/commit/15bde5352bd4bdb54105c0fdfd956c9ca420e4c6
- https://github.com/moodle/moodle/commit/339c6eca3c881742178637cb41cc7ebbe4a3b6b0
- https://github.com/moodle/moodle/commit/44e712e9b72a30c6bc01112040854e91f5758605
- https://github.com/moodle/moodle/commit/edc89dfecb3f6891cea019baf2aecce51b3de41a
- https://github.com/moodle/moodle
- https://web.archive.org/web/20150914064838/http://www.securitytracker.com/id/1031215
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2014-9060 · CVE Program
- CVE-2014-9060 · NVD
- FIRST EPSS
- GHSA-c87j-9rrq-h3j8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences