The gollum-grit_adapter Ruby gem dependency in gollum before 3.1.1 and the gollum-lib gem…
Priority MEDIUM 43CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
The gollum-grit_adapter Ruby gem dependency in gollum before 3.1.1 and the gollum-lib gem dependency in gollum-lib before 4.0.1 when the string "master" is in any of the wiki documents, allows remote authenticated users to execute arbitrary code via the -O or --open-files-in-pager flags.
Why it matters now
EPSS 0.02941 87th percentileScored 2026-11-07
Fix Fixed gollum (RubyGems): 3.1.1gollum-lib (RubyGems): 4.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | gollum (RubyGems) | before 3.1.1 | 3.1.1 | Patch available | GHSA-q97v-764g-r2rp |
| — | gollum-lib (RubyGems) | before 4.0.1 | 4.0.1 | Patch available | GHSA-q97v-764g-r2rp |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- gollum (RubyGems) Vendor— Affected before 3.1.1 Fixed in 3.1.1 Patch available GHSA-q97v-764g-r2rp
- gollum-lib (RubyGems) Vendor— Affected before 4.0.1 Fixed in 4.0.1 Patch available GHSA-q97v-764g-r2rp
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gollum_project:gollum:*:*:*:*:*:*:*:* | up to 3.1.0 | Vulnerable | Gollum Project |
| cpe:2.3:a:gollum_project:gollum-lib:*:*:*:*:*:*:*:* | up to 4.0.0 | Vulnerable | Gollum Project |
| cpe:2.3:a:gollum_project:grit_adapter:*:*:*:*:*:*:*:* | up to 0.1.0 | Vulnerable | Gollum Project |
- cpe:2.3:a:gollum_project:gollum:*:*:*:*:*:*:*:* Versions up to 3.1.0 Vulnerable ·Gollum Project
- cpe:2.3:a:gollum_project:gollum-lib:*:*:*:*:*:*:*:* Versions up to 4.0.0 Vulnerable ·Gollum Project
- cpe:2.3:a:gollum_project:grit_adapter:*:*:*:*:*:*:*:* Versions up to 0.1.0 Vulnerable ·Gollum Project
Remediation
- Fix · GHSA-q97v-764g-r2rp gollum (RubyGems) Fixed in 3.1.1 Advisory →
- Fix · GHSA-q97v-764g-r2rp gollum-lib (RubyGems) Fixed in 4.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-9489
- 2026-10-03 Alias added: GHSA-q97v-764g-r2rp
References
Patch 2
More Gollum Project Gollum vulnerabilities
- TI-2020-17935 Cross site scripting (XSS) in gollum 5.0 to 5.1.2 via the filename parameter to the 'New Page' dialog. CVSS 3.1MEDIUM 6.1
- TI-2015-06082 The Precious module in gollum before 4.0.1 allows remote attackers to read arbitrary… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2014-9489 · CVE Program
- CVE-2014-9489 · NVD
- FIRST EPSS
- GHSA-q97v-764g-r2rp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences