The Precious module in gollum before 4.0.1 allows remote attackers to read arbitrary…
Priority LOW 24CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
The Precious module in gollum before 4.0.1 allows remote attackers to read arbitrary files by leveraging the lack of a certain temporary-file check.
Why it matters now
EPSS 0.01876 79th percentileScored 2026-11-07
Fix Fixed gollum (RubyGems): 4.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | gollum (RubyGems) | before 4.0.1 | 4.0.1 | Patch available | GHSA-m2q3-53fq-7h66 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- gollum (RubyGems) Vendor— Affected before 4.0.1 Fixed in 4.0.1 Patch available GHSA-m2q3-53fq-7h66
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gollum_project:gollum:*:*:*:*:*:*:*:* | up to 4.0 | Vulnerable | Gollum Project |
- cpe:2.3:a:gollum_project:gollum:*:*:*:*:*:*:*:* Versions up to 4.0 Vulnerable ·Gollum Project
Remediation
- Fix · GHSA-m2q3-53fq-7h66 gollum (RubyGems) Fixed in 4.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-7314
- 2026-10-03 Alias added: GHSA-m2q3-53fq-7h66
References
Patch 2
More Gollum Project Gollum vulnerabilities
- TI-2014-07713 The gollum-grit_adapter Ruby gem dependency in gollum before 3.1.1 and the gollum-lib gem… CVSS 3.0HIGH 8.8
- TI-2020-17935 Cross site scripting (XSS) in gollum 5.0 to 5.1.2 via the filename parameter to the 'New Page' dialog. CVSS 3.1MEDIUM 6.1
Sources
- CVE-2015-7314 · CVE Program
- CVE-2015-7314 · NVD
- FIRST EPSS
- GHSA-m2q3-53fq-7h66 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences