codepeople cp-polls Plugin cp-admin-int-message-list.inc.php sql injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
A vulnerability has been found in codepeople cp-polls Plugin 1.0.1 on WordPress and classified as critical. This vulnerability affects unknown code of the file cp-admin-int-message-list.inc.php. The manipulation of the argument lu leads to sql injection. The attack can be initiated remotely. Upgrading to version 1.0.2 is able to address this issue. The name of the patch is 6d7168cbf12d1c183bacc5cd5678f6f5b0d518d2. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-222268.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| codepeople | cp-polls Plugin | 1.0.1 | — | No fix listed | CNA |
- cp-polls Plugin Vendorcodepeople Affected 1.0.1 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:codepeople:polls_cp:1.0.1:*:*:*:*:wordpress:*:* | 1.0.1 | Vulnerable | codepeople |
- cpe:2.3:a:codepeople:polls_cp:1.0.1:*:*:*:*:wordpress:*:* Versions 1.0.1 Vulnerable ·codepeople
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2014-125091
- 2026-10-03 Alias added: GHSA-5prc-vv8w-f9r4
References
More codepeople Polls Cp vulnerabilities
- TI-2024-08220 Polls CP <= 1.0.75 - Admin+ Stored XSS via Custom Styles CVSS 3.1MEDIUM 5.4
- TI-2024-08217 Polls CP <= 1.0.75 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
- TI-2015-07723 The cp-polls plugin before 1.0.5 for WordPress has XSS. CVSS 3.0MEDIUM 6.1
- TI-2014-08257 The cp-polls plugin before 1.0.1 for WordPress has XSS in the votes list. CVSS 3.0MEDIUM 6.1
Sources
- CVE-2014-125091 · CVE Program
- CVE-2014-125091 · NVD
- FIRST EPSS
- GHSA-5prc-vv8w-f9r4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences