Polls CP <= 1.0.75 - Admin+ Stored Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Polls CP WordPress plugin before 1.0.77 does not sanitise and escape some of its poll settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multi site setup).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Polls CP | before 1.0.77 | 1.0.77 | Patch available | CNA |
- Polls CP VendorUnknown Affected before 1.0.77 Fixed in 1.0.77 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:codepeople:polls_cp:*:*:*:*:*:wordpress:*:* | before 1.0.77 | Vulnerable | codepeople |
- cpe:2.3:a:codepeople:polls_cp:*:*:*:*:*:wordpress:*:* Versions before 1.0.77 Vulnerable ·codepeople
Remediation
- Fix · CNA Polls CP (Unknown) Fixed in 1.0.77
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Polls CP 1.0.77
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2024-08220 Polls CP <= 1.0.75 - Admin+ Stored XSS via Custom StylesPriority MEDIUM 58
Timeline
- 2026-10-02 Threatist record created from CVE-2024-8851
- 2026-10-03 Alias added: GHSA-ccp4-cg9p-v3f5
References
More codepeople Polls Cp vulnerabilities
- TI-2024-08220 Polls CP <= 1.0.75 - Admin+ Stored XSS via Custom Styles CVSS 3.1MEDIUM 5.4
- TI-2014-08391 codepeople cp-polls Plugin cp-admin-int-message-list.inc.php sql injection CVSS 3.1CRITICAL 9.8
- TI-2015-07723 The cp-polls plugin before 1.0.5 for WordPress has XSS. CVSS 3.0MEDIUM 6.1
- TI-2014-08257 The cp-polls plugin before 1.0.1 for WordPress has XSS in the votes list. CVSS 3.0MEDIUM 6.1
Sources
- CVE-2024-8851 · CVE Program
- CVE-2024-8851 · NVD
- FIRST EPSS
- GHSA-ccp4-cg9p-v3f5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences