Read the docs

MaxButtons Plugin maxbuttons-button.php maxbuttons_strip_px cross site scripting

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

A vulnerability was found in MaxButtons Plugin up to 1.26.0 on WordPress and classified as problematic. This issue affects the function maxbuttons_strip_px of the file includes/maxbuttons-button.php. The manipulation of the argument button_id leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 1.26.1 is able to address this issue. The patch is named e74564c9e3b7429808e317f4916bd1c26ef0b806. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-222323.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00531 45th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—MaxButtons Plugin1.0; 1.1; 1.2; 1.3; 1.4; 1.5; 1.6; 1.7; 1.8; 1.9; 1.10; 1.11; 1.12; 1.13; 1.14; 1.15; 1.16; 1.17; 1.18; 1.19; 1.20; 1.21; 1.22; 1.23; 1.24; 1.25; 1.26—No fix listedCNA
  • MaxButtons Plugin Vendor— Affected 1.0; 1.1; 1.2; 1.3; 1.4; 1.5; 1.6; 1.7; 1.8; 1.9; 1.10; 1.11; 1.12; 1.13; 1.14; 1.15; 1.16; 1.17; 1.18; 1.19; 1.20; 1.21; 1.22; 1.23; 1.24; 1.25; 1.26 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:maxfoundry:maxbuttons:*:*:*:*:*:wordpress:*:*before 1.26.1Vulnerablemaxfoundry
  • cpe:2.3:a:maxfoundry:maxbuttons:*:*:*:*:*:wordpress:*:* Versions before 1.26.1 Vulnerable ·maxfoundry

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2014-125092
  2. 2026-10-03 Alias added: GHSA-7mh4-2xvc-88jh

References

  • TI-2024-02833 WordPress Button Plugin MaxButtons < 9.7.8 - Editor+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2024-09778 MaxButtons < 9.8.1 - Admin+ Stored XSS via Button Width CVSS 3.1MEDIUM 4.8
  • TI-2024-08328 MaxButtons < 9.8.1 - Admin+ Stored XSS via Text Color CVSS 3.1MEDIUM 4.7
  • TI-2022-16688 WordPress MaxButtons plugin <= 9.2 - Multiple Cross-Site Request Forgery (CSRF) vulnerabilities CVSS 3.1HIGH 8.8
  • TI-2024-06028 WordPress Button Plugin MaxButtons <= 9.7.8 - Full Path Disclosure CVSS 3.1MEDIUM 5.3
  • TI-2023-18342 WordPress MaxButtons Plugin <= 9.5.3 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
See all 10 →

Sources