Read the docs
TI-2024-02833 Aliases CVE-2024-3026GHSA-8h2w-mrjw-fq93

WordPress Button Plugin MaxButtons < 9.7.8 - Editor+ Stored XSS

Priority MEDIUM 58CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The WordPress Button Plugin MaxButtons WordPress plugin before 9.7.8 does not sanitise and escape some parameters, which could allow users with a role as low as editor to perform Cross-Site Scripting attacks

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00492 42nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WordPress Button Plugin MaxButtons (Unknown): 9.7.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWordPress Button Plugin MaxButtonsbefore 9.7.89.7.8Patch availableCNA
  • WordPress Button Plugin MaxButtons VendorUnknown Affected before 9.7.8 Fixed in 9.7.8 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:maxfoundry:maxbuttons:*:*:*:*:*:wordpress:*:*before 9.7.8Vulnerablemaxfoundry
  • cpe:2.3:a:maxfoundry:maxbuttons:*:*:*:*:*:wordpress:*:* Versions before 9.7.8 Vulnerable ·maxfoundry

Remediation

  • Fix · CNA WordPress Button Plugin MaxButtons (Unknown) Fixed in 9.7.8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-3026
  2. 2026-10-03 Alias added: GHSA-8h2w-mrjw-fq93

References

  • TI-2024-09778 MaxButtons < 9.8.1 - Admin+ Stored XSS via Button Width CVSS 3.1MEDIUM 4.8
  • TI-2024-08328 MaxButtons < 9.8.1 - Admin+ Stored XSS via Text Color CVSS 3.1MEDIUM 4.7
  • TI-2022-16688 WordPress MaxButtons plugin <= 9.2 - Multiple Cross-Site Request Forgery (CSRF) vulnerabilities CVSS 3.1HIGH 8.8
  • TI-2024-06028 WordPress Button Plugin MaxButtons <= 9.7.8 - Full Path Disclosure CVSS 3.1MEDIUM 5.3
  • TI-2023-18342 WordPress MaxButtons Plugin <= 9.5.3 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
  • TI-2023-06426 WordPress Button Plugin MaxButtons <= 9.7.6 - Authenticated(Contributor+) Stored Cross-Site Scripting via shortcode CVSS 3.1MEDIUM 6.4
See all 10 →

Sources