MaxButtons < 9.8.1 - Admin+ Stored XSS via Button Width
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The WordPress Button Plugin MaxButtons WordPress plugin before 9.8.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WordPress Button Plugin MaxButtons | before 9.8.1 | 9.8.1 | Patch available | CNA |
- WordPress Button Plugin MaxButtons VendorUnknown Affected before 9.8.1 Fixed in 9.8.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:maxfoundry:maxbuttons:*:*:*:*:*:wordpress:*:* | before 9.8.1 | Vulnerable | maxfoundry |
- cpe:2.3:a:maxfoundry:maxbuttons:*:*:*:*:*:wordpress:*:* Versions before 9.8.1 Vulnerable ·maxfoundry
Remediation
- Fix · CNA WordPress Button Plugin MaxButtons (Unknown) Fixed in 9.8.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
WordPress Button Plugin MaxButtons 9.8.1
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2024-08328 MaxButtons < 9.8.1 - Admin+ Stored XSS via Text ColorPriority MEDIUM 55
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10555
- 2026-10-03 Alias added: GHSA-xrq3-j5cq-h7p4
References
More maxfoundry Maxbuttons vulnerabilities
- TI-2024-02833 WordPress Button Plugin MaxButtons < 9.7.8 - Editor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-08328 MaxButtons < 9.8.1 - Admin+ Stored XSS via Text Color CVSS 3.1MEDIUM 4.7
- TI-2022-16688 WordPress MaxButtons plugin <= 9.2 - Multiple Cross-Site Request Forgery (CSRF) vulnerabilities CVSS 3.1HIGH 8.8
- TI-2024-06028 WordPress Button Plugin MaxButtons <= 9.7.8 - Full Path Disclosure CVSS 3.1MEDIUM 5.3
- TI-2023-18342 WordPress MaxButtons Plugin <= 9.5.3 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2023-06426 WordPress Button Plugin MaxButtons <= 9.7.6 - Authenticated(Contributor+) Stored Cross-Site Scripting via shortcode CVSS 3.1MEDIUM 6.4
Sources
- CVE-2024-10555 · CVE Program
- CVE-2024-10555 · NVD
- FIRST EPSS
- GHSA-xrq3-j5cq-h7p4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences