BestWebSoft Contact Form Plugin bws_menu.php bws_add_menu_render cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A vulnerability was found in BestWebSoft Contact Form Plugin 1.3.4 on WordPress and classified as problematic. Affected by this issue is the function bws_add_menu_render of the file bws_menu/bws_menu.php. The manipulation of the argument bwsmn_form_email leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.3.7 is able to address this issue. The name of the patch is 4d531f74b4a801c805dc80360d4ea1312e9a278f. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-225320.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| BestWebSoft | Contact Form Plugin | 1.3.4 | — | No fix listed | CNA |
- Contact Form Plugin VendorBestWebSoft Affected 1.3.4 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:bestwebsoft:contact_form:1.3.4:*:*:*:*:wordpress:*:* | 1.3.4 | Vulnerable | BestWebSoft |
- cpe:2.3:a:bestwebsoft:contact_form:1.3.4:*:*:*:*:wordpress:*:* Versions 1.3.4 Vulnerable ·BestWebSoft
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2014-125095
- 2026-10-03 Alias added: GHSA-7hf8-264p-qj7q
References
More BestWebSoft Contact Form vulnerabilities
- TI-2017-14121 BestWebSoft Contact Form Plugin Stored cross site scriting CVSS 3.1MEDIUM 5.4
- TI-2012-05433 BestWebSoft Contact Form contact_form.php cntctfrm_settings_page cross-site request forgery CVSS 3.1HIGH 8.8
- TI-2017-13664 The contact-form-plugin plugin before 4.0.6 for WordPress has multiple XSS issues. CVSS 3.0MEDIUM 6.1
- TI-2017-01471 Cross-site scripting in BestWebSoft Captcha CVSS 3.0MEDIUM 6.1
- TI-2016-08907 The contact-form-plugin plugin before 4.0.2 for WordPress has XSS. CVSS 3.0MEDIUM 6.1
- TI-2015-07672 The contact-form-plugin plugin before 3.96 for WordPress has XSS. CVSS 3.0MEDIUM 6.1
Sources
- CVE-2014-125095 · CVE Program
- CVE-2014-125095 · NVD
- FIRST EPSS
- GHSA-7hf8-264p-qj7q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences