filter/mediaplugin/filter.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before…
Priority LOW 34CWE-399Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Complete
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-399 and the CVSS impact.
Summary
filter/mediaplugin/filter.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to cause a denial of service (CPU consumption or partial outage) via a crafted string that is matched against an improper regular expression.
Why it matters now
EPSS 0.02224 82nd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.6.7, 2.7.4, 2.8.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | before 2.6.7 | 2.6.7 | Patch available | GHSA-p497-37fc-xvvc |
| — | moodle/moodle (Packagist) | 2.7.0 to before 2.7.4 | 2.7.4 | Patch available | GHSA-p497-37fc-xvvc |
| — | moodle/moodle (Packagist) | 2.8.0 to before 2.8.2 | 2.8.2 | Patch available | GHSA-p497-37fc-xvvc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected before 2.6.7 Fixed in 2.6.7 Patch available GHSA-p497-37fc-xvvc
- moodle/moodle (Packagist) Vendor— Affected 2.7.0 to before 2.7.4 Fixed in 2.7.4 Patch available GHSA-p497-37fc-xvvc
- moodle/moodle (Packagist) Vendor— Affected 2.8.0 to before 2.8.2 Fixed in 2.8.2 Patch available GHSA-p497-37fc-xvvc
CPE configurations NVD · 22
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | up to 2.5.9 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.0:*:*:*:*:*:*:* | 2.5.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.1:*:*:*:*:*:*:* | 2.5.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.2:*:*:*:*:*:*:* | 2.5.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.3:*:*:*:*:*:*:* | 2.5.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.4:*:*:*:*:*:*:* | 2.5.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.5:*:*:*:*:*:*:* | 2.5.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.6:*:*:*:*:*:*:* | 2.5.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.7:*:*:*:*:*:*:* | 2.5.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.8:*:*:*:*:*:*:* | 2.5.8 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions up to 2.5.9 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.1:*:*:*:*:*:*:* Versions 2.5.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.2:*:*:*:*:*:*:* Versions 2.5.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.3:*:*:*:*:*:*:* Versions 2.5.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.4:*:*:*:*:*:*:* Versions 2.5.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.5:*:*:*:*:*:*:* Versions 2.5.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.6:*:*:*:*:*:*:* Versions 2.5.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.7:*:*:*:*:*:*:* Versions 2.5.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.8:*:*:*:*:*:*:* Versions 2.5.8 Vulnerable ·Moodle
Show 12 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.6.0:*:*:*:*:*:*:* | 2.6.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.1:*:*:*:*:*:*:* | 2.6.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.2:*:*:*:*:*:*:* | 2.6.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.3:*:*:*:*:*:*:* | 2.6.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.4:*:*:*:*:*:*:* | 2.6.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.5:*:*:*:*:*:*:* | 2.6.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.6:*:*:*:*:*:*:* | 2.6.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:* | 2.7.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:* | 2.7.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:* | 2.7.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.3:*:*:*:*:*:*:* | 2.7.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* | 2.8.0 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.6.0:*:*:*:*:*:*:* Versions 2.6.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.1:*:*:*:*:*:*:* Versions 2.6.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.2:*:*:*:*:*:*:* Versions 2.6.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.3:*:*:*:*:*:*:* Versions 2.6.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.4:*:*:*:*:*:*:* Versions 2.6.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.5:*:*:*:*:*:*:* Versions 2.6.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.6:*:*:*:*:*:*:* Versions 2.6.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:* Versions 2.7.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:* Versions 2.7.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.3:*:*:*:*:*:*:* Versions 2.7.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Moodle
Remediation
- Fix · GHSA-p497-37fc-xvvc moodle/moodle (Packagist) Fixed in 2.6.7 Advisory →
- Fix · GHSA-p497-37fc-xvvc moodle/moodle (Packagist) Fixed in 2.7.4 Advisory →
- Fix · GHSA-p497-37fc-xvvc moodle/moodle (Packagist) Fixed in 2.8.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-0217
- 2026-10-03 Alias added: GHSA-p497-37fc-xvvc
References
Advisory 2
Other 10
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-48546
- [oss-security] 20150119 Moodle security issues are now public
- https://github.com/moodle/moodle/commit/01da07a42be0f69de9f316be6ee8cb25ecd60c19
- https://github.com/moodle/moodle/commit/25191bc31187f6381ad9fc690b653414ea3bc6d4
- https://github.com/moodle/moodle/commit/531492a32cf77f90bc48c4868a5f71dd7040049f
- https://github.com/moodle/moodle/commit/5329d84f0b5767f5bb800b203bfb89753ac35146
- https://github.com/moodle/moodle/commit/63ed941a9363b6da3322df2b8de5be0d1df6d81a
- https://github.com/moodle/moodle/commit/70229b7ec718ee3929109c54de74a8d14264a166
- https://github.com/moodle/moodle/commit/d11969e7775b0fc1a2debf6ec91e42d25b0eeecd
- https://github.com/moodle/moodle
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2015-0217 · CVE Program
- CVE-2015-0217 · NVD
- FIRST EPSS
- GHSA-p497-37fc-xvvc · GitHub Advisory Database · CC BY 4.0
- CVE-2015-0217 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences