Cross-site request forgery (CSRF) vulnerability in auth/shibboleth/logout.php in Moodle…
Priority LOW 32CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Tampering
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Cross-site request forgery (CSRF) vulnerability in auth/shibboleth/logout.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote attackers to hijack the authentication of arbitrary users for requests that trigger a logout.
Why it matters now
EPSS 0.01006 63rd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.6.7, 2.7.4, 2.8.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | before 2.6.7 | 2.6.7 | Patch available | GHSA-5jph-mvfm-r27p |
| — | moodle/moodle (Packagist) | 2.7.0 to before 2.7.4 | 2.7.4 | Patch available | GHSA-5jph-mvfm-r27p |
| — | moodle/moodle (Packagist) | 2.8.0 to before 2.8.2 | 2.8.2 | Patch available | GHSA-5jph-mvfm-r27p |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected before 2.6.7 Fixed in 2.6.7 Patch available GHSA-5jph-mvfm-r27p
- moodle/moodle (Packagist) Vendor— Affected 2.7.0 to before 2.7.4 Fixed in 2.7.4 Patch available GHSA-5jph-mvfm-r27p
- moodle/moodle (Packagist) Vendor— Affected 2.8.0 to before 2.8.2 Fixed in 2.8.2 Patch available GHSA-5jph-mvfm-r27p
CPE configurations NVD · 22
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | up to 2.5.9 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.0:*:*:*:*:*:*:* | 2.5.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.1:*:*:*:*:*:*:* | 2.5.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.2:*:*:*:*:*:*:* | 2.5.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.3:*:*:*:*:*:*:* | 2.5.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.4:*:*:*:*:*:*:* | 2.5.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.5:*:*:*:*:*:*:* | 2.5.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.6:*:*:*:*:*:*:* | 2.5.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.7:*:*:*:*:*:*:* | 2.5.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.5.8:*:*:*:*:*:*:* | 2.5.8 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions up to 2.5.9 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.1:*:*:*:*:*:*:* Versions 2.5.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.2:*:*:*:*:*:*:* Versions 2.5.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.3:*:*:*:*:*:*:* Versions 2.5.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.4:*:*:*:*:*:*:* Versions 2.5.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.5:*:*:*:*:*:*:* Versions 2.5.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.6:*:*:*:*:*:*:* Versions 2.5.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.7:*:*:*:*:*:*:* Versions 2.5.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.5.8:*:*:*:*:*:*:* Versions 2.5.8 Vulnerable ·Moodle
Show 12 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.6.0:*:*:*:*:*:*:* | 2.6.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.1:*:*:*:*:*:*:* | 2.6.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.2:*:*:*:*:*:*:* | 2.6.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.3:*:*:*:*:*:*:* | 2.6.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.4:*:*:*:*:*:*:* | 2.6.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.5:*:*:*:*:*:*:* | 2.6.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.6.6:*:*:*:*:*:*:* | 2.6.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:* | 2.7.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:* | 2.7.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:* | 2.7.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.3:*:*:*:*:*:*:* | 2.7.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* | 2.8.0 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.6.0:*:*:*:*:*:*:* Versions 2.6.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.1:*:*:*:*:*:*:* Versions 2.6.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.2:*:*:*:*:*:*:* Versions 2.6.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.3:*:*:*:*:*:*:* Versions 2.6.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.4:*:*:*:*:*:*:* Versions 2.6.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.5:*:*:*:*:*:*:* Versions 2.6.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.6.6:*:*:*:*:*:*:* Versions 2.6.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:* Versions 2.7.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:* Versions 2.7.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.3:*:*:*:*:*:*:* Versions 2.7.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Moodle
Remediation
- Fix · GHSA-5jph-mvfm-r27p moodle/moodle (Packagist) Fixed in 2.6.7 Advisory →
- Fix · GHSA-5jph-mvfm-r27p moodle/moodle (Packagist) Fixed in 2.7.4 Advisory →
- Fix · GHSA-5jph-mvfm-r27p moodle/moodle (Packagist) Fixed in 2.8.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-0218
- 2026-10-03 Alias added: GHSA-5jph-mvfm-r27p
References
Advisory 2
Other 7
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-47964
- [oss-security] 20150119 Moodle security issues are now public
- https://github.com/moodle/moodle/commit/371d58d70d4ef866f35e33ea6898007112bfe654
- https://github.com/moodle/moodle/commit/693918c30e6b7c95dddd9c5973f98d98342a59d9
- https://github.com/moodle/moodle/commit/b82b4c562b705ea8f11893d9126889bb696b9612
- https://github.com/moodle/moodle/commit/fb60e23a67931eeba8fc9aacf3cc838e462f21f2
- https://github.com/moodle/moodle
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2015-0218 · CVE Program
- CVE-2015-0218 · NVD
- FIRST EPSS
- GHSA-5jph-mvfm-r27p · GitHub Advisory Database · CC BY 4.0
- CVE-2015-0218 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences