Read the docs
TI-2015-01354 Aliases CVE-2015-1493GHSA-gphj-63h8-r9vq

Directory traversal vulnerability in the min_get_slash_argument function in…

Priority LOW 35CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Complete · None · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.

Summary

Directory traversal vulnerability in the min_get_slash_argument function in lib/configonlylib.php in Moodle through 2.5.9, 2.6.x before 2.6.8, 2.7.x before 2.7.5, and 2.8.x before 2.8.3 allows remote authenticated users to read arbitrary files via a .. (dot dot) in the file parameter, as demonstrated by reading PHP scripts.

Why it matters now

EPSS 0.02619 85th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.6.8, 2.7.5, 2.8.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—moodle/moodle (Packagist)before 2.6.82.6.8Patch availableGHSA-gphj-63h8-r9vq
—moodle/moodle (Packagist)2.7.0 to before 2.7.52.7.5Patch availableGHSA-gphj-63h8-r9vq
—moodle/moodle (Packagist)2.8.0 to before 2.8.32.8.3Patch availableGHSA-gphj-63h8-r9vq
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected before 2.6.8 Fixed in 2.6.8 Patch available GHSA-gphj-63h8-r9vq
  • moodle/moodle (Packagist) Vendor— Affected 2.7.0 to before 2.7.5 Fixed in 2.7.5 Patch available GHSA-gphj-63h8-r9vq
  • moodle/moodle (Packagist) Vendor— Affected 2.8.0 to before 2.8.3 Fixed in 2.8.3 Patch available GHSA-gphj-63h8-r9vq

CPE configurations NVD · 27

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*up to 2.5.9VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.0:*:*:*:*:*:*:*2.5.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.1:*:*:*:*:*:*:*2.5.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.2:*:*:*:*:*:*:*2.5.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.3:*:*:*:*:*:*:*2.5.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.4:*:*:*:*:*:*:*2.5.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.5:*:*:*:*:*:*:*2.5.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.6:*:*:*:*:*:*:*2.5.6VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.7:*:*:*:*:*:*:*2.5.7VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.8:*:*:*:*:*:*:*2.5.8VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions up to 2.5.9 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.1:*:*:*:*:*:*:* Versions 2.5.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.2:*:*:*:*:*:*:* Versions 2.5.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.3:*:*:*:*:*:*:* Versions 2.5.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.4:*:*:*:*:*:*:* Versions 2.5.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.5:*:*:*:*:*:*:* Versions 2.5.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.6:*:*:*:*:*:*:* Versions 2.5.6 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.7:*:*:*:*:*:*:* Versions 2.5.7 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.8:*:*:*:*:*:*:* Versions 2.5.8 Vulnerable ·Moodle
Show 17 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:2.6.0:*:*:*:*:*:*:*2.6.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.1:*:*:*:*:*:*:*2.6.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.2:*:*:*:*:*:*:*2.6.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.3:*:*:*:*:*:*:*2.6.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.4:*:*:*:*:*:*:*2.6.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.5:*:*:*:*:*:*:*2.6.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.6:*:*:*:*:*:*:*2.6.6VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.7:*:*:*:*:*:*:*2.6.7VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.8:*:*:*:*:*:*:*2.6.8VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:*2.7.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:*2.7.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:*2.7.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.3:*:*:*:*:*:*:*2.7.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.4:*:*:*:*:*:*:*2.7.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:*2.8.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:*2.8.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:*2.8.2VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:2.6.0:*:*:*:*:*:*:* Versions 2.6.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.1:*:*:*:*:*:*:* Versions 2.6.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.2:*:*:*:*:*:*:* Versions 2.6.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.3:*:*:*:*:*:*:* Versions 2.6.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.4:*:*:*:*:*:*:* Versions 2.6.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.5:*:*:*:*:*:*:* Versions 2.6.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.6:*:*:*:*:*:*:* Versions 2.6.6 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.7:*:*:*:*:*:*:* Versions 2.6.7 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.8:*:*:*:*:*:*:* Versions 2.6.8 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:* Versions 2.7.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:* Versions 2.7.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.3:*:*:*:*:*:*:* Versions 2.7.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.4:*:*:*:*:*:*:* Versions 2.7.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:* Versions 2.8.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:* Versions 2.8.2 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-gphj-63h8-r9vq moodle/moodle (Packagist) Fixed in 2.6.8 Advisory →
  • Fix · GHSA-gphj-63h8-r9vq moodle/moodle (Packagist) Fixed in 2.7.5 Advisory →
  • Fix · GHSA-gphj-63h8-r9vq moodle/moodle (Packagist) Fixed in 2.8.3 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2015-1493
  2. 2026-10-03 Alias added: GHSA-gphj-63h8-r9vq

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources