Server-side request forgery (SSRF) vulnerability in the proxy endpoint (api/v1/proxy) in…
Priority LOW 30CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
Server-side request forgery (SSRF) vulnerability in the proxy endpoint (api/v1/proxy) in Apache Ambari before 2.1.0 allows remote authenticated users to conduct port scans and access unsecured services via a crafted REST call.
Why it matters now
EPSS 0.02953 87th percentileScored 2026-11-07
Fix Fixed org.apache.ambari:ambari (Maven): 2.1.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.ambari:ambari (Maven) | 1.5.0 to before 2.1.0 | 2.1.0 | Patch available | GHSA-9g2j-5685-h44h |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.ambari:ambari (Maven) Vendor— Affected 1.5.0 to before 2.1.0 Fixed in 2.1.0 Patch available GHSA-9g2j-5685-h44h
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:ambari:1.5.0:*:*:*:*:*:*:* | 1.5.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:ambari:1.5.1:*:*:*:*:*:*:* | 1.5.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:ambari:1.6.0:*:*:*:*:*:*:* | 1.6.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:ambari:1.6.1:*:*:*:*:*:*:* | 1.6.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:ambari:1.7.0:*:*:*:*:*:*:* | 1.7.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:ambari:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:ambari:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:ambari:2.0.2:*:*:*:*:*:*:* | 2.0.2 | Vulnerable | Apache |
- cpe:2.3:a:apache:ambari:1.5.0:*:*:*:*:*:*:* Versions 1.5.0 Vulnerable ·Apache
- cpe:2.3:a:apache:ambari:1.5.1:*:*:*:*:*:*:* Versions 1.5.1 Vulnerable ·Apache
- cpe:2.3:a:apache:ambari:1.6.0:*:*:*:*:*:*:* Versions 1.6.0 Vulnerable ·Apache
- cpe:2.3:a:apache:ambari:1.6.1:*:*:*:*:*:*:* Versions 1.6.1 Vulnerable ·Apache
- cpe:2.3:a:apache:ambari:1.7.0:*:*:*:*:*:*:* Versions 1.7.0 Vulnerable ·Apache
- cpe:2.3:a:apache:ambari:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:ambari:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Apache
- cpe:2.3:a:apache:ambari:2.0.2:*:*:*:*:*:*:* Versions 2.0.2 Vulnerable ·Apache
Remediation
- Fix · GHSA-9g2j-5685-h44h org.apache.ambari:ambari (Maven) Fixed in 2.1.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-1775
- 2026-10-03 Alias added: GHSA-9g2j-5685-h44h
References
Advisory 2
More Apache Ambari vulnerabilities
- TI-2016-05848 Improper access control in Apache Ambari CVSS 3.0CRITICAL 9.8
- TI-2017-03642 During installation of Ambari 2.4.0 through 2.4.2, Ambari Server artifacts are not created with proper ACLs. CVSS 3.0CRITICAL 9.8
- TI-2014-02906 In Ambari 1.2.0 through 2.2.2, it may be possible to execute arbitrary system commands on… CVSS 3.0CRITICAL 9.8
- TI-2025-16981 Apache Ambari: Code Injection Vulnerability in Ambari Alert Definition CVSS 3.1HIGH 8.8
- TI-2024-34845 Apache Ambari: Remote Code Injection in Ambari Metrics and AMS Alerts CVSS 3.1HIGH 8.8
- TI-2023-27565 Apache Ambari: authenticated users could perform command injection to perform RCE CVSS 3.1HIGH 8.8
Sources
- CVE-2015-1775 · CVE Program
- CVE-2015-1775 · NVD
- FIRST EPSS
- GHSA-9g2j-5685-h44h · GitHub Advisory Database · CC BY 4.0
- CVE-2015-1775 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences