Apache Ambari: authenticated users could perform command injection to perform RCE
Priority MEDIUM 42CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Malicious code injection in Apache Ambari in prior to 2.7.8. Users are recommended to upgrade to version 2.7.8, which fixes this issue. Impact: A Cluster Operator can manipulate the request by adding a malicious code injection and gain a root over the cluster main host.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01064 64th percentileScored 2026-11-07
Fix Fixed org.apache.ambari.contrib.views:ambari-contrib-views (Maven): 2.7.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Ambari | 2.7.0 – 2.7.7 | — | No fix listed | CNA |
| — | org.apache.ambari.contrib.views:ambari-contrib-views (Maven) | 2.7.0 to before 2.7.8 | 2.7.8 | Patch available | GHSA-rghc-9fhx-h32m |
- Apache Ambari VendorApache Affected 2.7.0 – 2.7.7 Fixed in — No fix listed CNA
- org.apache.ambari.contrib.views:ambari-contrib-views (Maven) Vendor— Affected 2.7.0 to before 2.7.8 Fixed in 2.7.8 Patch available GHSA-rghc-9fhx-h32m
Remediation
- Fix · GHSA-rghc-9fhx-h32m org.apache.ambari.contrib.views:ambari-contrib-views (Maven) Fixed in 2.7.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-50379
- 2026-10-03 Alias added: GHSA-rghc-9fhx-h32m
References
More Apache Ambari vulnerabilities
- TI-2016-05848 Improper access control in Apache Ambari CVSS 3.0CRITICAL 9.8
- TI-2017-03642 During installation of Ambari 2.4.0 through 2.4.2, Ambari Server artifacts are not created with proper ACLs. CVSS 3.0CRITICAL 9.8
- TI-2014-02906 In Ambari 1.2.0 through 2.2.2, it may be possible to execute arbitrary system commands on… CVSS 3.0CRITICAL 9.8
- TI-2025-16981 Apache Ambari: Code Injection Vulnerability in Ambari Alert Definition CVSS 3.1HIGH 8.8
- TI-2024-34845 Apache Ambari: Remote Code Injection in Ambari Metrics and AMS Alerts CVSS 3.1HIGH 8.8
- TI-2022-22657 Apache Ambari: Allows authenticated metrics consumers to perform RCE CVSS 3.1HIGH 8.8
Sources
- CVE-2023-50379 · CVE Program
- CVE-2023-50379 · NVD
- FIRST EPSS
- GHSA-rghc-9fhx-h32m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences