Apache Ambari: Code Injection Vulnerability in Ambari Alert Definition
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-77.
Summary
A code injection vulnerability exists in the Ambari Alert Definition feature, allowing authenticated users to inject and execute arbitrary shell commands. The vulnerability arises when defining alert scripts, where the script filename field is executed using `sh -c`. An attacker with authenticated access can exploit this vulnerability to inject malicious commands, leading to remote code execution on the server. The issue has been fixed in the latest versions of Ambari.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Apache Ambari (Apache Software Foundation) Fixed in 2.7.9
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache Ambari 2.7.9
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2025-16980 Apache Ambari: XML External Entity (XXE) Vulnerability in Ambari/OoziePriority MEDIUM 40
Timeline
- 2026-10-02 Threatist record created from CVE-2025-23196
- 2026-10-03 Alias added: GHSA-37rh-2c9j-68mm
References
More Apache Ambari vulnerabilities
- TI-2016-05848 Improper access control in Apache Ambari CVSS 3.0CRITICAL 9.8
- TI-2017-03642 During installation of Ambari 2.4.0 through 2.4.2, Ambari Server artifacts are not created with proper ACLs. CVSS 3.0CRITICAL 9.8
- TI-2014-02906 In Ambari 1.2.0 through 2.2.2, it may be possible to execute arbitrary system commands on… CVSS 3.0CRITICAL 9.8
- TI-2024-34845 Apache Ambari: Remote Code Injection in Ambari Metrics and AMS Alerts CVSS 3.1HIGH 8.8
- TI-2023-27565 Apache Ambari: authenticated users could perform command injection to perform RCE CVSS 3.1HIGH 8.8
- TI-2022-22657 Apache Ambari: Allows authenticated metrics consumers to perform RCE CVSS 3.1HIGH 8.8
Sources
- CVE-2025-23196 · CVE Program
- CVE-2025-23196 · NVD
- FIRST EPSS
- GHSA-37rh-2c9j-68mm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences