Multiple cross-site scripting (XSS) vulnerabilities in the MAGMI (aka Magento Mass…
Priority LOW 35CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Multiple cross-site scripting (XSS) vulnerabilities in the MAGMI (aka Magento Mass Importer) plugin for Magento Server allow remote attackers to inject arbitrary web script or HTML via the (1) profile parameter to web/magmi.php or (2) QUERY_STRING to web/magmi_import_run.php.
Why it matters now
EPSS 0.1404 96th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD and the CNA
Fix Fixed dweeves/magmi (Packagist): 0.7.22
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | dweeves/magmi (Packagist) | before 0.7.22 | 0.7.22 | Patch available | GHSA-27v2-398x-f74x |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- dweeves/magmi (Packagist) Vendor— Affected before 0.7.22 Fixed in 0.7.22 Patch available GHSA-27v2-398x-f74x
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:magmi_project:magmi:-:*:*:*:*:magento_server:*:* | not specified by NVD | Vulnerable | Magmi Project |
- cpe:2.3:a:magmi_project:magmi:-:*:*:*:*:magento_server:*:* Versions not specified by NVD Vulnerable ·Magmi Project
Remediation
- Fix · GHSA-27v2-398x-f74x dweeves/magmi (Packagist) Fixed in 0.7.22 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-2068
- 2026-10-03 Alias added: GHSA-27v2-398x-f74x
References
More Magmi Project Magmi vulnerabilities
- TI-2020-04705 Improper authentication in MAGMI CVSS 3.1CRITICAL 9.8
- TI-2020-04704 Cross-site request forgery in MAGMI CVSS 3.1HIGH 8.8
- TI-2015-01854 Directory traversal vulnerability in web/ajax_pluginconf.php in the MAGMI (aka Magento… CVSS 2.0MEDIUM 5.0
- TI-2014-07198 Unrestricted file upload vulnerability in magmi/web/magmi.php in the MAGMI (aka Magento… CVSS 2.0HIGH 9.0
- TI-2017-05045 A Cross-Site Scripting (XSS) was discovered in 'Magmi 0.7.22'. CVSS 3.0MEDIUM 6.1
Sources
- CVE-2015-2068 · CVE Program
- CVE-2015-2068 · NVD
- FIRST EPSS
- GHSA-27v2-398x-f74x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences