Improper authentication in MAGMI
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
MAGMI versions prior to 0.7.24 are vulnerable to a remote authentication bypass due to allowing default credentials in the event there is a database connection failure. A remote attacker can trigger this connection failure if the Mysql setting max_connections (default 151) is lower than Apache (or another web server) setting MaxRequestWorkers (formerly MaxClients) (default 256). This can be done by sending at least 151 simultaneous requests to the Magento website to trigger a "Too many connections" error, then use default magmi:magmi basic authentication to remotely bypass authentication.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | MAGMI | All versions prior to version 0.7.24 | — | No fix listed | CNA |
| — | dweeves/magmi (Packagist) | before 0.7.24 | 0.7.24 | Patch available | GHSA-g475-pch5-6wvv |
- MAGMI Vendor— Affected All versions prior to version 0.7.24 Fixed in — No fix listed CNA
- dweeves/magmi (Packagist) Vendor— Affected before 0.7.24 Fixed in 0.7.24 Patch available GHSA-g475-pch5-6wvv
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:magmi_project:magmi:*:*:*:*:*:*:*:* | before 0.7.24 | Vulnerable | Magmi Project |
- cpe:2.3:a:magmi_project:magmi:*:*:*:*:*:*:*:* Versions before 0.7.24 Vulnerable ·Magmi Project
Remediation
- Fix · GHSA-g475-pch5-6wvv dweeves/magmi (Packagist) Fixed in 0.7.24 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-5777
- 2026-10-03 Alias added: GHSA-g475-pch5-6wvv
References
More Magmi Project Magmi vulnerabilities
- TI-2020-04704 Cross-site request forgery in MAGMI CVSS 3.1HIGH 8.8
- TI-2015-01854 Directory traversal vulnerability in web/ajax_pluginconf.php in the MAGMI (aka Magento… CVSS 2.0MEDIUM 5.0
- TI-2014-07198 Unrestricted file upload vulnerability in magmi/web/magmi.php in the MAGMI (aka Magento… CVSS 2.0HIGH 9.0
- TI-2017-05045 A Cross-Site Scripting (XSS) was discovered in 'Magmi 0.7.22'. CVSS 3.0MEDIUM 6.1
- TI-2015-01855 Multiple cross-site scripting (XSS) vulnerabilities in the MAGMI (aka Magento Mass… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2020-5777 · CVE Program
- CVE-2020-5777 · NVD
- FIRST EPSS
- GHSA-g475-pch5-6wvv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences