A Cross-Site Scripting (XSS) was discovered in 'Magmi 0.7.22'.
Priority LOW 38CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A Cross-Site Scripting (XSS) was discovered in 'Magmi 0.7.22'. The vulnerability exists due to insufficient filtration of user-supplied data (prefix) passed to the 'magmi-git-master/magmi/web/ajax_gettime.php' URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.
Why it matters now
EPSS 0.08279 94th percentileScored 2026-11-07
Fix Fixed dweeves/magmi (Packagist): 0.7.24
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | dweeves/magmi (Packagist) | before 0.7.24 | 0.7.24 | Patch available | GHSA-r8vh-cm9f-rc29 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- dweeves/magmi (Packagist) Vendor— Affected before 0.7.24 Fixed in 0.7.24 Patch available GHSA-r8vh-cm9f-rc29
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:magmi_project:magmi:0.7.22:*:*:*:*:*:*:* | 0.7.22 | Vulnerable | Magmi Project |
- cpe:2.3:a:magmi_project:magmi:0.7.22:*:*:*:*:*:*:* Versions 0.7.22 Vulnerable ·Magmi Project
Remediation
- Fix · GHSA-r8vh-cm9f-rc29 dweeves/magmi (Packagist) Fixed in 0.7.24 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-7391
- 2026-10-03 Alias added: GHSA-r8vh-cm9f-rc29
References
More Magmi Project Magmi vulnerabilities
- TI-2020-04705 Improper authentication in MAGMI CVSS 3.1CRITICAL 9.8
- TI-2020-04704 Cross-site request forgery in MAGMI CVSS 3.1HIGH 8.8
- TI-2015-01854 Directory traversal vulnerability in web/ajax_pluginconf.php in the MAGMI (aka Magento… CVSS 2.0MEDIUM 5.0
- TI-2014-07198 Unrestricted file upload vulnerability in magmi/web/magmi.php in the MAGMI (aka Magento… CVSS 2.0HIGH 9.0
- TI-2015-01855 Multiple cross-site scripting (XSS) vulnerabilities in the MAGMI (aka Magento Mass… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2017-7391 · CVE Program
- CVE-2017-7391 · NVD
- FIRST EPSS
- GHSA-r8vh-cm9f-rc29 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences