Read the docs
TI-2015-02013 Aliases CVE-2015-2273GHSA-w77v-xpxr-c6pv

Cross-site scripting (XSS) vulnerability in…

Priority LOW 20CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · Partial · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Cross-site scripting (XSS) vulnerability in mod/quiz/report/statistics/statistics_question_table.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allows remote authenticated users to inject arbitrary web script or HTML by leveraging the student role for a crafted quiz response.

Why it matters now

EPSS 0.01449 73rd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.6.9, 2.7.6, 2.8.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—moodle/moodle (Packagist)before 2.6.92.6.9Patch availableGHSA-w77v-xpxr-c6pv
—moodle/moodle (Packagist)2.7.0 to before 2.7.62.7.6Patch availableGHSA-w77v-xpxr-c6pv
—moodle/moodle (Packagist)2.8.0 to before 2.8.42.8.4Patch availableGHSA-w77v-xpxr-c6pv
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected before 2.6.9 Fixed in 2.6.9 Patch available GHSA-w77v-xpxr-c6pv
  • moodle/moodle (Packagist) Vendor— Affected 2.7.0 to before 2.7.6 Fixed in 2.7.6 Patch available GHSA-w77v-xpxr-c6pv
  • moodle/moodle (Packagist) Vendor— Affected 2.8.0 to before 2.8.4 Fixed in 2.8.4 Patch available GHSA-w77v-xpxr-c6pv

CPE configurations NVD · 29

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*up to 2.5.9VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.0:*:*:*:*:*:*:*2.5.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.1:*:*:*:*:*:*:*2.5.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.2:*:*:*:*:*:*:*2.5.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.3:*:*:*:*:*:*:*2.5.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.4:*:*:*:*:*:*:*2.5.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.5:*:*:*:*:*:*:*2.5.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.6:*:*:*:*:*:*:*2.5.6VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.7:*:*:*:*:*:*:*2.5.7VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.5.8:*:*:*:*:*:*:*2.5.8VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions up to 2.5.9 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.1:*:*:*:*:*:*:* Versions 2.5.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.2:*:*:*:*:*:*:* Versions 2.5.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.3:*:*:*:*:*:*:* Versions 2.5.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.4:*:*:*:*:*:*:* Versions 2.5.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.5:*:*:*:*:*:*:* Versions 2.5.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.6:*:*:*:*:*:*:* Versions 2.5.6 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.7:*:*:*:*:*:*:* Versions 2.5.7 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.5.8:*:*:*:*:*:*:* Versions 2.5.8 Vulnerable ·Moodle
Show 19 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:2.6.0:*:*:*:*:*:*:*2.6.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.1:*:*:*:*:*:*:*2.6.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.2:*:*:*:*:*:*:*2.6.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.3:*:*:*:*:*:*:*2.6.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.4:*:*:*:*:*:*:*2.6.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.5:*:*:*:*:*:*:*2.6.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.6:*:*:*:*:*:*:*2.6.6VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.7:*:*:*:*:*:*:*2.6.7VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.8:*:*:*:*:*:*:*2.6.8VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:*2.7.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:*2.7.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:*2.7.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.3:*:*:*:*:*:*:*2.7.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.4:*:*:*:*:*:*:*2.7.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.5:*:*:*:*:*:*:*2.7.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:*2.8.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:*2.8.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:*2.8.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.3:*:*:*:*:*:*:*2.8.3VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:2.6.0:*:*:*:*:*:*:* Versions 2.6.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.1:*:*:*:*:*:*:* Versions 2.6.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.2:*:*:*:*:*:*:* Versions 2.6.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.3:*:*:*:*:*:*:* Versions 2.6.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.4:*:*:*:*:*:*:* Versions 2.6.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.5:*:*:*:*:*:*:* Versions 2.6.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.6:*:*:*:*:*:*:* Versions 2.6.6 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.7:*:*:*:*:*:*:* Versions 2.6.7 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.8:*:*:*:*:*:*:* Versions 2.6.8 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:* Versions 2.7.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:* Versions 2.7.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.3:*:*:*:*:*:*:* Versions 2.7.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.4:*:*:*:*:*:*:* Versions 2.7.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.5:*:*:*:*:*:*:* Versions 2.7.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:* Versions 2.8.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:* Versions 2.8.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.3:*:*:*:*:*:*:* Versions 2.8.3 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-w77v-xpxr-c6pv moodle/moodle (Packagist) Fixed in 2.6.9 Advisory →
  • Fix · GHSA-w77v-xpxr-c6pv moodle/moodle (Packagist) Fixed in 2.7.6 Advisory →
  • Fix · GHSA-w77v-xpxr-c6pv moodle/moodle (Packagist) Fixed in 2.8.4 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2015-2273
  2. 2026-10-03 Alias added: GHSA-w77v-xpxr-c6pv

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources