Read the docs
TI-2015-02895 Aliases CVE-2015-3274GHSA-f7qm-q26p-6rr2

Cross-site scripting (XSS) vulnerability in the user_get_user_details function in…

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Cross-site scripting (XSS) vulnerability in the user_get_user_details function in user/lib.php in Moodle through 2.6.11, 2.7.x before 2.7.9, 2.8.x before 2.8.7, and 2.9.x before 2.9.1 allows remote attackers to inject arbitrary web script or HTML by leveraging absence of an external_format_text call in a web service.

Why it matters now

EPSS 0.01465 73rd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.7.9, 2.8.7, 2.9.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—moodle/moodle (Packagist)2.7.0 to before 2.7.92.7.9Patch availableGHSA-f7qm-q26p-6rr2
—moodle/moodle (Packagist)2.8.0 to before 2.8.72.8.7Patch availableGHSA-f7qm-q26p-6rr2
—moodle/moodle (Packagist)2.9.0 to before 2.9.12.9.1Patch availableGHSA-f7qm-q26p-6rr2
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 2.7.0 to before 2.7.9 Fixed in 2.7.9 Patch available GHSA-f7qm-q26p-6rr2
  • moodle/moodle (Packagist) Vendor— Affected 2.8.0 to before 2.8.7 Fixed in 2.8.7 Patch available GHSA-f7qm-q26p-6rr2
  • moodle/moodle (Packagist) Vendor— Affected 2.9.0 to before 2.9.1 Fixed in 2.9.1 Patch available GHSA-f7qm-q26p-6rr2

CPE configurations NVD · 28

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:2.6.0:*:*:*:*:*:*:*2.6.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.1:*:*:*:*:*:*:*2.6.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.2:*:*:*:*:*:*:*2.6.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.3:*:*:*:*:*:*:*2.6.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.4:*:*:*:*:*:*:*2.6.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.5:*:*:*:*:*:*:*2.6.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.6:*:*:*:*:*:*:*2.6.6VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.7:*:*:*:*:*:*:*2.6.7VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.8:*:*:*:*:*:*:*2.6.8VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.6.9:*:*:*:*:*:*:*2.6.9VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:2.6.0:*:*:*:*:*:*:* Versions 2.6.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.1:*:*:*:*:*:*:* Versions 2.6.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.2:*:*:*:*:*:*:* Versions 2.6.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.3:*:*:*:*:*:*:* Versions 2.6.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.4:*:*:*:*:*:*:* Versions 2.6.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.5:*:*:*:*:*:*:* Versions 2.6.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.6:*:*:*:*:*:*:* Versions 2.6.6 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.7:*:*:*:*:*:*:* Versions 2.6.7 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.8:*:*:*:*:*:*:* Versions 2.6.8 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.6.9:*:*:*:*:*:*:* Versions 2.6.9 Vulnerable ·Moodle
Show 18 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:2.6.10:*:*:*:*:*:*:*2.6.10VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:*2.7.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:*2.7.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:*2.7.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.3:*:*:*:*:*:*:*2.7.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.4:*:*:*:*:*:*:*2.7.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.5:*:*:*:*:*:*:*2.7.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.6:*:*:*:*:*:*:*2.7.6VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.7:*:*:*:*:*:*:*2.7.7VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.8:*:*:*:*:*:*:*2.7.8VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:*2.8.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:*2.8.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:*2.8.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.3:*:*:*:*:*:*:*2.8.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.4:*:*:*:*:*:*:*2.8.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.5:*:*:*:*:*:*:*2.8.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.6:*:*:*:*:*:*:*2.8.6VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.9.0:*:*:*:*:*:*:*2.9.0VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:2.6.10:*:*:*:*:*:*:* Versions 2.6.10 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:* Versions 2.7.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:* Versions 2.7.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.3:*:*:*:*:*:*:* Versions 2.7.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.4:*:*:*:*:*:*:* Versions 2.7.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.5:*:*:*:*:*:*:* Versions 2.7.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.6:*:*:*:*:*:*:* Versions 2.7.6 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.7:*:*:*:*:*:*:* Versions 2.7.7 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.8:*:*:*:*:*:*:* Versions 2.7.8 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:* Versions 2.8.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:* Versions 2.8.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.3:*:*:*:*:*:*:* Versions 2.8.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.4:*:*:*:*:*:*:* Versions 2.8.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.5:*:*:*:*:*:*:* Versions 2.8.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.6:*:*:*:*:*:*:* Versions 2.8.6 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.9.0:*:*:*:*:*:*:* Versions 2.9.0 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-f7qm-q26p-6rr2 moodle/moodle (Packagist) Fixed in 2.7.9 Advisory →
  • Fix · GHSA-f7qm-q26p-6rr2 moodle/moodle (Packagist) Fixed in 2.8.7 Advisory →
  • Fix · GHSA-f7qm-q26p-6rr2 moodle/moodle (Packagist) Fixed in 2.9.1 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2015-3274
  2. 2026-10-03 Alias added: GHSA-f7qm-q26p-6rr2

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources