Directory traversal vulnerability in Elasticsearch before 1.4.5 and 1.5.x before 1.5.2…
Priority MEDIUM 45CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-22 and the CVSS impact.
Summary
Directory traversal vulnerability in Elasticsearch before 1.4.5 and 1.5.x before 1.5.2, when a site plugin is enabled, allows remote attackers to read arbitrary files via unspecified vectors.
Why it matters now
EPSS 0.3316 98th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Partial org.elasticsearch:elasticsearch (Maven): 1.4.5, 1.5.2Red Hat: 3 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.elasticsearch:elasticsearch (Maven) | before 1.4.5 | 1.4.5 | Patch available | GHSA-x8q8-4hp5-463w |
| — | org.elasticsearch:elasticsearch (Maven) | 1.5.0 to before 1.5.2 | 1.5.2 | Patch available | GHSA-x8q8-4hp5-463w |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.elasticsearch:elasticsearch (Maven) Vendor— Affected before 1.4.5 Fixed in 1.4.5 Patch available GHSA-x8q8-4hp5-463w
- org.elasticsearch:elasticsearch (Maven) Vendor— Affected 1.5.0 to before 1.5.2 Fixed in 1.5.2 Patch available GHSA-x8q8-4hp5-463w
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:elasticsearch:elasticsearch:*:*:*:*:*:*:*:* | up to 1.4.4 | Vulnerable | Elasticsearch |
| cpe:2.3:a:elasticsearch:elasticsearch:1.5.0:*:*:*:*:*:*:* | 1.5.0 | Vulnerable | Elasticsearch |
| cpe:2.3:a:elasticsearch:elasticsearch:1.5.1:*:*:*:*:*:*:* | 1.5.1 | Vulnerable | Elasticsearch |
- cpe:2.3:a:elasticsearch:elasticsearch:*:*:*:*:*:*:*:* Versions up to 1.4.4 Vulnerable ·Elasticsearch
- cpe:2.3:a:elasticsearch:elasticsearch:1.5.0:*:*:*:*:*:*:* Versions 1.5.0 Vulnerable ·Elasticsearch
- cpe:2.3:a:elasticsearch:elasticsearch:1.5.1:*:*:*:*:*:*:* Versions 1.5.1 Vulnerable ·Elasticsearch
Remediation
- Fix · GHSA-x8q8-4hp5-463w org.elasticsearch:elasticsearch (Maven) Fixed in 1.4.5 Advisory →
- Fix · GHSA-x8q8-4hp5-463w org.elasticsearch:elasticsearch (Maven) Fixed in 1.5.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Enterprise 2 | Affected | — |
| Red Hat Satellite 6 | Affected | — |
| Red Hat Subscription Asset Manager | Affected | — |
Timeline
- 2026-10-02 Threatist record created from CVE-2015-3337
- 2026-10-03 Alias added: GHSA-x8q8-4hp5-463w
References
More Elasticsearch vulnerabilities
- TI-2015-04656 Directory traversal vulnerability in Elasticsearch before 1.6.1 allows remote attackers… CVSS 2.0MEDIUM 5.0
- TI-2015-03491 The snapshot API in Elasticsearch before 1.6.0 when another application exists on the… CVSS 3.0HIGH 7.5
- TI-2014-05292 Cross-site scripting (XSS) vulnerability in the CORS functionality in Elasticsearch… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2015-3337 · CVE Program
- CVE-2015-3337 · NVD
- FIRST EPSS
- GHSA-x8q8-4hp5-463w · GitHub Advisory Database · CC BY 4.0
- CVE-2015-3337 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences