Read the docs
TI-2015-04656 Aliases CVE-2015-5531GHSA-jjq8-vfjq-j6v4

Directory traversal vulnerability in Elasticsearch before 1.6.1 allows remote attackers…

Priority HIGH 67CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Partial · None · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.

Summary

Directory traversal vulnerability in Elasticsearch before 1.6.1 allows remote attackers to read arbitrary files via unspecified vectors related to snapshot API calls.

Why it matters now

EPSS 0.94788 99th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed org.elasticsearch:elasticsearch (Maven): 1.6.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.elasticsearch:elasticsearch (Maven)before 1.6.11.6.1Patch availableGHSA-jjq8-vfjq-j6v4
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.elasticsearch:elasticsearch (Maven) Vendor— Affected before 1.6.1 Fixed in 1.6.1 Patch available GHSA-jjq8-vfjq-j6v4

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:elasticsearch:elasticsearch:*:*:*:*:*:*:*:*up to 1.6.0VulnerableElasticsearch
  • cpe:2.3:a:elasticsearch:elasticsearch:*:*:*:*:*:*:*:* Versions up to 1.6.0 Vulnerable ·Elasticsearch

Remediation

  • Fix · GHSA-jjq8-vfjq-j6v4 org.elasticsearch:elasticsearch (Maven) Fixed in 1.6.1 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

Not affected: 2 products
  • Red Hat Satellite 6
  • Red Hat Subscription Asset Manager

Timeline

  1. 2026-10-02 Threatist record created from CVE-2015-5531
  2. 2026-10-03 Alias added: GHSA-jjq8-vfjq-j6v4

References

  • TI-2015-02950 Directory traversal vulnerability in Elasticsearch before 1.4.5 and 1.5.x before 1.5.2… CVSS 2.0MEDIUM 4.3
  • TI-2015-03491 The snapshot API in Elasticsearch before 1.6.0 when another application exists on the… CVSS 3.0HIGH 7.5
  • TI-2014-05292 Cross-site scripting (XSS) vulnerability in the CORS functionality in Elasticsearch… CVSS 2.0MEDIUM 4.3

Sources