Stack-based buffer overflow in hw/scsi/scsi-bus.c in QEMU, when built with SCSI-device…
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-787 and the CVSS impact.
Summary
Stack-based buffer overflow in hw/scsi/scsi-bus.c in QEMU, when built with SCSI-device emulation support, allows guest OS users with CAP_SYS_RAWIO permissions to cause a denial of service (instance crash) via an invalid opcode in a SCSI command descriptor block.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:* | 2.2.0 to before 2.4.0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:2.4.0:-:*:*:*:*:*:* | 2.4.0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:2.4.0:rc1:*:*:*:*:*:* | 2.4.0 rc1 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:2.4.0:rc2:*:*:*:*:*:* | 2.4.0 rc2 | Vulnerable | QEMU |
- cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:* Versions 2.2.0 to before 2.4.0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:2.4.0:-:*:*:*:*:*:* Versions 2.4.0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:2.4.0:rc1:*:*:*:*:*:* Versions 2.4.0 rc1 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:2.4.0:rc2:*:*:*:*:*:* Versions 2.4.0 rc2 Vulnerable ·QEMU
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 7 | Affected | No fix yet |
Not affected: 6 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux OpenStack Platform 5 (Icehouse)
- Red Hat Enterprise Linux OpenStack Platform 6 (Juno)
- Red Hat Enterprise Linux OpenStack Platform 7 (Kilo)
Timeline
- 2026-10-02 Threatist record created from CVE-2015-5158
- 2026-10-03 Alias added: GHSA-gx3q-72jh-pq5j
References
More Qemu vulnerabilities
- TI-2024-16148 QEMU before 8.2.0 has an integer underflow, and resultant buffer overflow, via a TI… CVSS 3.1HIGH 8.8
- TI-2022-02736 Uncontrolled resource consumption in QEMU CVSS 3.1HIGH 7.8
- TI-2023-02681 Qemu: 9pfs: improper access control on special files CVSS 3.1HIGH 7.1
- TI-2019-09678 The QMP migrate command in QEMU version 4.0.0 and earlier is vulnerable to OS command… CVSS 3.0CRITICAL 9.8
- TI-2024-03326 Qemu-kvm: net: assertion failure in update_sctp_checksum() CVSS 3.1MEDIUM 5.5
- TI-2023-22631 QEMU through 8.0.0 could trigger a division by zero in scsi_disk_reset in… CVSS 3.1MEDIUM 5.5
Sources
- CVE-2015-5158 · CVE Program
- CVE-2015-5158 · NVD
- FIRST EPSS
- GHSA-gx3q-72jh-pq5j · GitHub Advisory Database · CC BY 4.0
- CVE-2015-5158 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences