Open redirect vulnerability in Apache Ambari before 2.1.2 allows remote attackers to…
Priority LOW 33CWE-601Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Partial · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-601.
Summary
Open redirect vulnerability in Apache Ambari before 2.1.2 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via a URL in the targetURI parameter.
Why it matters now
EPSS 0.04119 90th percentileScored 2026-11-07
Fix Fixed org.apache.ambari:ambari (Maven): 2.1.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.ambari:ambari (Maven) | 1.7.0 to before 2.1.2 | 2.1.2 | Patch available | GHSA-w3p6-94x2-xcvm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.ambari:ambari (Maven) Vendor— Affected 1.7.0 to before 2.1.2 Fixed in 2.1.2 Patch available GHSA-w3p6-94x2-xcvm
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:ambari:*:*:*:*:*:*:*:* | up to 2.1.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:ambari:1.7.0:*:*:*:*:*:*:* | 1.7.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:ambari:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:ambari:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:ambari:2.0.2:*:*:*:*:*:*:* | 2.0.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:ambari:2.1.0:*:*:*:*:*:*:* | 2.1.0 | Vulnerable | Apache |
- cpe:2.3:a:apache:ambari:*:*:*:*:*:*:*:* Versions up to 2.1.1 Vulnerable ·Apache
- cpe:2.3:a:apache:ambari:1.7.0:*:*:*:*:*:*:* Versions 1.7.0 Vulnerable ·Apache
- cpe:2.3:a:apache:ambari:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:ambari:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Apache
- cpe:2.3:a:apache:ambari:2.0.2:*:*:*:*:*:*:* Versions 2.0.2 Vulnerable ·Apache
- cpe:2.3:a:apache:ambari:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Apache
Remediation
- Fix · GHSA-w3p6-94x2-xcvm org.apache.ambari:ambari (Maven) Fixed in 2.1.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-5210
- 2026-10-03 Alias added: GHSA-w3p6-94x2-xcvm
References
Advisory 2
More Apache Ambari vulnerabilities
- TI-2016-05848 Improper access control in Apache Ambari CVSS 3.0CRITICAL 9.8
- TI-2017-03642 During installation of Ambari 2.4.0 through 2.4.2, Ambari Server artifacts are not created with proper ACLs. CVSS 3.0CRITICAL 9.8
- TI-2014-02906 In Ambari 1.2.0 through 2.2.2, it may be possible to execute arbitrary system commands on… CVSS 3.0CRITICAL 9.8
- TI-2025-16981 Apache Ambari: Code Injection Vulnerability in Ambari Alert Definition CVSS 3.1HIGH 8.8
- TI-2024-34845 Apache Ambari: Remote Code Injection in Ambari Metrics and AMS Alerts CVSS 3.1HIGH 8.8
- TI-2023-27565 Apache Ambari: authenticated users could perform command injection to perform RCE CVSS 3.1HIGH 8.8
Sources
- CVE-2015-5210 · CVE Program
- CVE-2015-5210 · NVD
- FIRST EPSS
- GHSA-w3p6-94x2-xcvm · GitHub Advisory Database · CC BY 4.0
- CVE-2015-5210 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences