Read the docs
TI-2015-04425 Aliases CVE-2015-5266GHSA-454r-4cjv-vc9h

The enrol_meta_sync function in enrol/meta/locallib.php in Moodle through 2.6.11, 2.7.x…

Priority LOW 33CWE-264Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
High
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.

Summary

The enrol_meta_sync function in enrol/meta/locallib.php in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to obtain manager privileges in opportunistic circumstances by leveraging incorrect role processing during a long-running sync script.

Why it matters now

EPSS 0.01567 75th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.7.10, 2.8.8, 2.9.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—moodle/moodle (Packagist)2.7.0 to before 2.7.102.7.10Patch availableGHSA-454r-4cjv-vc9h
—moodle/moodle (Packagist)2.8.0 to before 2.8.82.8.8Patch availableGHSA-454r-4cjv-vc9h
—moodle/moodle (Packagist)2.9.0 to before 2.9.22.9.2Patch availableGHSA-454r-4cjv-vc9h
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 2.7.0 to before 2.7.10 Fixed in 2.7.10 Patch available GHSA-454r-4cjv-vc9h
  • moodle/moodle (Packagist) Vendor— Affected 2.8.0 to before 2.8.8 Fixed in 2.8.8 Patch available GHSA-454r-4cjv-vc9h
  • moodle/moodle (Packagist) Vendor— Affected 2.9.0 to before 2.9.2 Fixed in 2.9.2 Patch available GHSA-454r-4cjv-vc9h

CPE configurations NVD · 21

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*up to 2.6.11VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:*2.7.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:*2.7.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:*2.7.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.3:*:*:*:*:*:*:*2.7.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.4:*:*:*:*:*:*:*2.7.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.5:*:*:*:*:*:*:*2.7.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.6:*:*:*:*:*:*:*2.7.6VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.7:*:*:*:*:*:*:*2.7.7VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.7.8:*:*:*:*:*:*:*2.7.8VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions up to 2.6.11 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:* Versions 2.7.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:* Versions 2.7.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.3:*:*:*:*:*:*:* Versions 2.7.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.4:*:*:*:*:*:*:* Versions 2.7.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.5:*:*:*:*:*:*:* Versions 2.7.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.6:*:*:*:*:*:*:* Versions 2.7.6 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.7:*:*:*:*:*:*:* Versions 2.7.7 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.7.8:*:*:*:*:*:*:* Versions 2.7.8 Vulnerable ·Moodle
Show 11 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:2.7.9:*:*:*:*:*:*:*2.7.9VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:*2.8.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:*2.8.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:*2.8.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.3:*:*:*:*:*:*:*2.8.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.4:*:*:*:*:*:*:*2.8.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.5:*:*:*:*:*:*:*2.8.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.6:*:*:*:*:*:*:*2.8.6VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.8.7:*:*:*:*:*:*:*2.8.7VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.9.0:*:*:*:*:*:*:*2.9.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.9.1:*:*:*:*:*:*:*2.9.1VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:2.7.9:*:*:*:*:*:*:* Versions 2.7.9 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:* Versions 2.8.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:* Versions 2.8.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.3:*:*:*:*:*:*:* Versions 2.8.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.4:*:*:*:*:*:*:* Versions 2.8.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.5:*:*:*:*:*:*:* Versions 2.8.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.6:*:*:*:*:*:*:* Versions 2.8.6 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.8.7:*:*:*:*:*:*:* Versions 2.8.7 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.9.0:*:*:*:*:*:*:* Versions 2.9.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.9.1:*:*:*:*:*:*:* Versions 2.9.1 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-454r-4cjv-vc9h moodle/moodle (Packagist) Fixed in 2.7.10 Advisory →
  • Fix · GHSA-454r-4cjv-vc9h moodle/moodle (Packagist) Fixed in 2.8.8 Advisory →
  • Fix · GHSA-454r-4cjv-vc9h moodle/moodle (Packagist) Fixed in 2.9.2 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2015-5266
  2. 2026-10-03 Alias added: GHSA-454r-4cjv-vc9h

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources