Cross-site scripting (XSS) vulnerability in group/overview.php in Moodle through 2.6.11…
Priority LOW 27CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in group/overview.php in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to inject arbitrary web script or HTML via a modified grouping description.
Why it matters now
EPSS 0.0117 67th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.7.10, 2.8.8, 2.9.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | before 2.7.10 | 2.7.10 | Patch available | GHSA-5729-822w-j342 |
| — | moodle/moodle (Packagist) | 2.8.0 to before 2.8.8 | 2.8.8 | Patch available | GHSA-5729-822w-j342 |
| — | moodle/moodle (Packagist) | 2.9.0 to before 2.9.2 | 2.9.2 | Patch available | GHSA-5729-822w-j342 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected before 2.7.10 Fixed in 2.7.10 Patch available GHSA-5729-822w-j342
- moodle/moodle (Packagist) Vendor— Affected 2.8.0 to before 2.8.8 Fixed in 2.8.8 Patch available GHSA-5729-822w-j342
- moodle/moodle (Packagist) Vendor— Affected 2.9.0 to before 2.9.2 Fixed in 2.9.2 Patch available GHSA-5729-822w-j342
CPE configurations NVD · 21
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | up to 2.6.11 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:* | 2.7.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:* | 2.7.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:* | 2.7.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.3:*:*:*:*:*:*:* | 2.7.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.4:*:*:*:*:*:*:* | 2.7.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.5:*:*:*:*:*:*:* | 2.7.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.6:*:*:*:*:*:*:* | 2.7.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.7:*:*:*:*:*:*:* | 2.7.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.8:*:*:*:*:*:*:* | 2.7.8 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions up to 2.6.11 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:* Versions 2.7.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:* Versions 2.7.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.3:*:*:*:*:*:*:* Versions 2.7.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.4:*:*:*:*:*:*:* Versions 2.7.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.5:*:*:*:*:*:*:* Versions 2.7.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.6:*:*:*:*:*:*:* Versions 2.7.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.7:*:*:*:*:*:*:* Versions 2.7.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.8:*:*:*:*:*:*:* Versions 2.7.8 Vulnerable ·Moodle
Show 11 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.7.9:*:*:*:*:*:*:* | 2.7.9 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* | 2.8.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:* | 2.8.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:* | 2.8.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.3:*:*:*:*:*:*:* | 2.8.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.4:*:*:*:*:*:*:* | 2.8.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.5:*:*:*:*:*:*:* | 2.8.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.6:*:*:*:*:*:*:* | 2.8.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.7:*:*:*:*:*:*:* | 2.8.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.0:*:*:*:*:*:*:* | 2.9.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.1:*:*:*:*:*:*:* | 2.9.1 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.7.9:*:*:*:*:*:*:* Versions 2.7.9 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:* Versions 2.8.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:* Versions 2.8.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.3:*:*:*:*:*:*:* Versions 2.8.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.4:*:*:*:*:*:*:* Versions 2.8.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.5:*:*:*:*:*:*:* Versions 2.8.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.6:*:*:*:*:*:*:* Versions 2.8.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.7:*:*:*:*:*:*:* Versions 2.8.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.0:*:*:*:*:*:*:* Versions 2.9.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.1:*:*:*:*:*:*:* Versions 2.9.1 Vulnerable ·Moodle
Remediation
- Fix · GHSA-5729-822w-j342 moodle/moodle (Packagist) Fixed in 2.7.10 Advisory →
- Fix · GHSA-5729-822w-j342 moodle/moodle (Packagist) Fixed in 2.8.8 Advisory →
- Fix · GHSA-5729-822w-j342 moodle/moodle (Packagist) Fixed in 2.9.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-5269
- 2026-10-03 Alias added: GHSA-5729-822w-j342
References
Advisory 2
Other 8
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-50709
- [oss-security] 20150921 Moodle security release
- https://github.com/moodle/moodle/commit/45f3b5302d645ba13ca8b68b0106a638ebd21980
- https://github.com/moodle/moodle/commit/a44fed5c804b52e82c334c37dcc1c12b77f97af8
- https://github.com/moodle/moodle/commit/ae6b18a9343083c1ab62d6eb535a7112bd7a3a50
- https://github.com/moodle/moodle/commit/fa5a3cdedcd92bd96881fa89a6ff5efd80bd3512
- https://github.com/moodle/moodle
- https://web.archive.org/web/20160323063809/http://www.securitytracker.com/id/1033619
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2015-5269 · CVE Program
- CVE-2015-5269 · NVD
- FIRST EPSS
- GHSA-5729-822w-j342 · GitHub Advisory Database · CC BY 4.0
- CVE-2015-5269 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences