Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3…
Priority LOW 23CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure, Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200 and CWE-264.
Summary
Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 does not consider the moodle/badges:viewbadges capability, which allows remote authenticated users to obtain sensitive badge information via a request involving (1) badges/overview.php or (2) badges/view.php.
Why it matters now
EPSS 0.01277 70th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.7.11, 2.8.9, 2.9.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | up to 2.6.11 | — | No fix listed | GHSA-mmvj-j7hq-rx85 |
| — | moodle/moodle (Packagist) | 2.7.0 to before 2.7.11 | 2.7.11 | Patch available | GHSA-mmvj-j7hq-rx85 |
| — | moodle/moodle (Packagist) | 2.8.0 to before 2.8.9 | 2.8.9 | Patch available | GHSA-mmvj-j7hq-rx85 |
| — | moodle/moodle (Packagist) | 2.9.0 to before 2.9.3 | 2.9.3 | Patch available | GHSA-mmvj-j7hq-rx85 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected up to 2.6.11 Fixed in — No fix listed GHSA-mmvj-j7hq-rx85
- moodle/moodle (Packagist) Vendor— Affected 2.7.0 to before 2.7.11 Fixed in 2.7.11 Patch available GHSA-mmvj-j7hq-rx85
- moodle/moodle (Packagist) Vendor— Affected 2.8.0 to before 2.8.9 Fixed in 2.8.9 Patch available GHSA-mmvj-j7hq-rx85
- moodle/moodle (Packagist) Vendor— Affected 2.9.0 to before 2.9.3 Fixed in 2.9.3 Patch available GHSA-mmvj-j7hq-rx85
CPE configurations NVD · 24
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | up to 2.6.11 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:* | 2.7.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:* | 2.7.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:* | 2.7.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.3:*:*:*:*:*:*:* | 2.7.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.4:*:*:*:*:*:*:* | 2.7.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.5:*:*:*:*:*:*:* | 2.7.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.6:*:*:*:*:*:*:* | 2.7.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.7:*:*:*:*:*:*:* | 2.7.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.8:*:*:*:*:*:*:* | 2.7.8 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions up to 2.6.11 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:* Versions 2.7.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:* Versions 2.7.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.3:*:*:*:*:*:*:* Versions 2.7.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.4:*:*:*:*:*:*:* Versions 2.7.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.5:*:*:*:*:*:*:* Versions 2.7.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.6:*:*:*:*:*:*:* Versions 2.7.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.7:*:*:*:*:*:*:* Versions 2.7.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.8:*:*:*:*:*:*:* Versions 2.7.8 Vulnerable ·Moodle
Show 14 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.7.9:*:*:*:*:*:*:* | 2.7.9 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.10:*:*:*:*:*:*:* | 2.7.10 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* | 2.8.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:* | 2.8.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:* | 2.8.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.3:*:*:*:*:*:*:* | 2.8.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.4:*:*:*:*:*:*:* | 2.8.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.5:*:*:*:*:*:*:* | 2.8.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.6:*:*:*:*:*:*:* | 2.8.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.7:*:*:*:*:*:*:* | 2.8.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.8:*:*:*:*:*:*:* | 2.8.8 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.0:*:*:*:*:*:*:* | 2.9.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.1:*:*:*:*:*:*:* | 2.9.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.2:*:*:*:*:*:*:* | 2.9.2 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.7.9:*:*:*:*:*:*:* Versions 2.7.9 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.10:*:*:*:*:*:*:* Versions 2.7.10 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:* Versions 2.8.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:* Versions 2.8.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.3:*:*:*:*:*:*:* Versions 2.8.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.4:*:*:*:*:*:*:* Versions 2.8.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.5:*:*:*:*:*:*:* Versions 2.8.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.6:*:*:*:*:*:*:* Versions 2.8.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.7:*:*:*:*:*:*:* Versions 2.8.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.8:*:*:*:*:*:*:* Versions 2.8.8 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.0:*:*:*:*:*:*:* Versions 2.9.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.1:*:*:*:*:*:*:* Versions 2.9.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.2:*:*:*:*:*:*:* Versions 2.9.2 Vulnerable ·Moodle
Remediation
- Fix · GHSA-mmvj-j7hq-rx85 moodle/moodle (Packagist) Fixed in 2.7.11 Advisory →
- Fix · GHSA-mmvj-j7hq-rx85 moodle/moodle (Packagist) Fixed in 2.8.9 Advisory →
- Fix · GHSA-mmvj-j7hq-rx85 moodle/moodle (Packagist) Fixed in 2.9.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-5340
- 2026-10-03 Alias added: GHSA-mmvj-j7hq-rx85
References
Advisory 2
Other 7
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-51684
- https://github.com/moodle/moodle/commit/47d5c29202e299fdbe54229d3f6b0c381835eae3
- https://github.com/moodle/moodle/commit/65734f149f3c7e6cce9402f51f9a97deb31170db
- https://github.com/moodle/moodle/commit/7cff64fdbfff749e779cb625fbddcce737355100
- https://github.com/moodle/moodle/commit/d41fa94a69bebeca69a4cd5332bb9569cfd87b99
- https://github.com/moodle/moodle/commit/d70f610615242c5c7b3ae0bf7ef6868520dcd850
- https://github.com/moodle/moodle
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2015-5340 · CVE Program
- CVE-2015-5340 · NVD
- FIRST EPSS
- GHSA-mmvj-j7hq-rx85 · GitHub Advisory Database · CC BY 4.0
- CVE-2015-5340 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences