The choice module in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and…
Priority LOW 23CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
The choice module in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 allows remote authenticated users to bypass intended access restrictions by visiting a URL to add or delete responses in the closed state.
Why it matters now
EPSS 0.01278 70th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.7.11, 2.8.9, 2.9.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | before 2.7.11 | 2.7.11 | Patch available | GHSA-6xpm-q8x9-j3rw |
| — | moodle/moodle (Packagist) | 2.8.0 to before 2.8.9 | 2.8.9 | Patch available | GHSA-6xpm-q8x9-j3rw |
| — | moodle/moodle (Packagist) | 2.9.0 to before 2.9.3 | 2.9.3 | Patch available | GHSA-6xpm-q8x9-j3rw |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected before 2.7.11 Fixed in 2.7.11 Patch available GHSA-6xpm-q8x9-j3rw
- moodle/moodle (Packagist) Vendor— Affected 2.8.0 to before 2.8.9 Fixed in 2.8.9 Patch available GHSA-6xpm-q8x9-j3rw
- moodle/moodle (Packagist) Vendor— Affected 2.9.0 to before 2.9.3 Fixed in 2.9.3 Patch available GHSA-6xpm-q8x9-j3rw
CPE configurations NVD · 24
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | up to 2.6.11 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:* | 2.7.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:* | 2.7.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:* | 2.7.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.3:*:*:*:*:*:*:* | 2.7.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.4:*:*:*:*:*:*:* | 2.7.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.5:*:*:*:*:*:*:* | 2.7.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.6:*:*:*:*:*:*:* | 2.7.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.7:*:*:*:*:*:*:* | 2.7.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.8:*:*:*:*:*:*:* | 2.7.8 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions up to 2.6.11 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:* Versions 2.7.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:* Versions 2.7.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.3:*:*:*:*:*:*:* Versions 2.7.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.4:*:*:*:*:*:*:* Versions 2.7.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.5:*:*:*:*:*:*:* Versions 2.7.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.6:*:*:*:*:*:*:* Versions 2.7.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.7:*:*:*:*:*:*:* Versions 2.7.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.8:*:*:*:*:*:*:* Versions 2.7.8 Vulnerable ·Moodle
Show 14 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.7.9:*:*:*:*:*:*:* | 2.7.9 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.7.10:*:*:*:*:*:*:* | 2.7.10 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* | 2.8.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:* | 2.8.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:* | 2.8.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.3:*:*:*:*:*:*:* | 2.8.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.4:*:*:*:*:*:*:* | 2.8.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.5:*:*:*:*:*:*:* | 2.8.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.6:*:*:*:*:*:*:* | 2.8.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.7:*:*:*:*:*:*:* | 2.8.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.8:*:*:*:*:*:*:* | 2.8.8 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.0:*:*:*:*:*:*:* | 2.9.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.1:*:*:*:*:*:*:* | 2.9.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.2:*:*:*:*:*:*:* | 2.9.2 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.7.9:*:*:*:*:*:*:* Versions 2.7.9 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.7.10:*:*:*:*:*:*:* Versions 2.7.10 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:* Versions 2.8.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:* Versions 2.8.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.3:*:*:*:*:*:*:* Versions 2.8.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.4:*:*:*:*:*:*:* Versions 2.8.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.5:*:*:*:*:*:*:* Versions 2.8.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.6:*:*:*:*:*:*:* Versions 2.8.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.7:*:*:*:*:*:*:* Versions 2.8.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.8:*:*:*:*:*:*:* Versions 2.8.8 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.0:*:*:*:*:*:*:* Versions 2.9.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.1:*:*:*:*:*:*:* Versions 2.9.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.2:*:*:*:*:*:*:* Versions 2.9.2 Vulnerable ·Moodle
Remediation
- Fix · GHSA-6xpm-q8x9-j3rw moodle/moodle (Packagist) Fixed in 2.7.11 Advisory →
- Fix · GHSA-6xpm-q8x9-j3rw moodle/moodle (Packagist) Fixed in 2.8.9 Advisory →
- Fix · GHSA-6xpm-q8x9-j3rw moodle/moodle (Packagist) Fixed in 2.9.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-5342
- 2026-10-03 Alias added: GHSA-6xpm-q8x9-j3rw
References
Advisory 2
Other 10
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-51569
- https://github.com/moodle/moodle/commit/02d8c8ca394ba053905f9b87c155042aabf0ce1b
- https://github.com/moodle/moodle/commit/09bb6f19e5814deb25ae6ceb8270063430b8941f
- https://github.com/moodle/moodle/commit/5c16db4fc561c97b6a907398ea081cdaf6590214
- https://github.com/moodle/moodle/commit/6283c33979001b035f9fc565b869296f66a61c4e
- https://github.com/moodle/moodle/commit/7ca8c34045eb0d2031652b452492fe4abb2c7c8a
- https://github.com/moodle/moodle/commit/97394274ee29f0a6eecab330b5bbb8ee335e7ece
- https://github.com/moodle/moodle/commit/bdaa571437c6357f322871b068f02a4520b7a23d
- https://github.com/moodle/moodle/commit/fb2491effb1a7d5d7abb0efba5b3929342990514
- https://github.com/moodle/moodle
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2015-5342 · CVE Program
- CVE-2015-5342 · NVD
- FIRST EPSS
- GHSA-6xpm-q8x9-j3rw · GitHub Advisory Database · CC BY 4.0
- CVE-2015-5342 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences