Read the docs
TI-2015-05457 Aliases CVE-2015-6497GHSA-j4fq-3fm7-wh5v

The create function in app/code/core/Mage/Catalog/Model/Product/Api/V2.php in Magento…

Priority MEDIUM 48CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

The create function in app/code/core/Mage/Catalog/Model/Product/Api/V2.php in Magento Community Edition (CE) before 1.9.2.1 and Enterprise Edition (EE) before 1.14.2.1, when used with PHP before 5.4.24 or 5.5.8, allows remote authenticated users to execute arbitrary PHP code via the productData parameter to index.php/api/v2_soap.

Why it matters now

EPSS 0.0737 94th percentileScored 2026-11-07
Public exploit Yes 4 exploit referencesTagged by NVD
Fix Fixed magento/core (Packagist): 1.9.2.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—magento/core (Packagist)before 1.9.2.11.9.2.1Patch availableGHSA-j4fq-3fm7-wh5v
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • magento/core (Packagist) Vendor— Affected before 1.9.2.1 Fixed in 1.9.2.1 Patch available GHSA-j4fq-3fm7-wh5v

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:magento:magento:*:*:*:*:community:*:*:*before 1.9.2.1VulnerableMagento
cpe:2.3:a:magento:magento:*:*:*:*:enterprise:*:*:*before 1.14.2.1VulnerableMagento
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*before 5.4.24; 5.4.25 to before 5.5.8Running onPHP
  • cpe:2.3:a:magento:magento:*:*:*:*:community:*:*:* Versions before 1.9.2.1 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:*:*:*:*:enterprise:*:*:* Versions before 1.14.2.1 Vulnerable ·Magento
  • cpe:2.3:a:php:php:*:*:*:*:*:*:*:* Versions before 5.4.24; 5.4.25 to before 5.5.8 Running on ·PHP

Remediation

  • Fix · GHSA-j4fq-3fm7-wh5v magento/core (Packagist) Fixed in 1.9.2.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2015-6497
  2. 2026-10-03 Alias added: GHSA-j4fq-3fm7-wh5v

References

  • TI-2016-03411 Magento CE and EE before 2.0.6 allows remote attackers to conduct PHP objection injection… CVSS 3.0CRITICAL 9.8
  • TI-2021-04135 Magento Commerce Reflected Cross-site Scripting Vulnerability Could Lead To Arbitrary JavaScript Execution CVSS 3.1MEDIUM 4.8
  • TI-2019-05058 SQL injection in Magento Open Source CVSS 3.0CRITICAL 9.8
  • TI-2015-01273 SQL injection vulnerability in the getCsvFile function in the… CVSS 2.0MEDIUM 6.5
  • TI-2022-15170 Adobe Commerce Stored XSS Arbitrary code execution CVSS 3.1MEDIUM 4.8
  • TI-2020-03231 Deserialization of untrusted data in Adobe Magento CVSS 3.1CRITICAL 9.8
See all 220 →

Sources