Read the docs
TI-2015-07290 Aliases CVE-2015-8860GHSA-gfjr-3jmm-4g9v

The tar package before 2.0.0 for Node.js allows remote attackers to write to arbitrary…

Priority MEDIUM 40CWE-59Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat.

Summary

The tar package before 2.0.0 for Node.js allows remote attackers to write to arbitrary files via a symlink attack in an archive.

Why it matters now

EPSS 0.04001 90th percentileScored 2026-11-07
Fix Partial tar (npm): 2.0.0Red Hat: 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—tar (npm)before 2.0.02.0.0Patch availableGHSA-gfjr-3jmm-4g9v
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • tar (npm) Vendor— Affected before 2.0.0 Fixed in 2.0.0 Patch available GHSA-gfjr-3jmm-4g9v

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:*up to 1.8.4VulnerableNodeJS
  • cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:* Versions up to 1.8.4 Vulnerable ·NodeJS

Remediation

  • Fix · GHSA-gfjr-3jmm-4g9v tar (npm) Fixed in 2.0.0 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Software CollectionsAffectedNo fix yet

Timeline

  1. 2026-10-02 Threatist record created from CVE-2015-8860
  2. 2026-10-03 Alias added: GHSA-gfjr-3jmm-4g9v

References

  • TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2016-01993 The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other… CVSS 3.1HIGH 7.5
  • TI-2024-03325 Command injection vulnerability in programing languages on Microsoft Windows operating system. CVSS 3.1CRITICAL 9.8
  • TI-2022-03472 X.509 Email Address Variable Length Buffer Overflow CVSS 3.1HIGH 7.5
  • TI-2022-03315 X.509 Email Address 4-byte Buffer Overflow CVSS 3.1HIGH 7.5
See all 186 →

Sources