admin/tool/monitor/lib.php in Event Monitor in Moodle 2.8.x before 2.8.11, 2.9.x before…
Priority LOW 23CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
admin/tool/monitor/lib.php in Event Monitor in Moodle 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does not consider the moodle/course:viewhiddencourses capability, which allows remote authenticated users to discover hidden course names by subscribing to a rule.
Why it matters now
EPSS 0.01693 77th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.8.11, 2.9.5, 3.0.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 2.8.0 to before 2.8.11 | 2.8.11 | Patch available | GHSA-fmq9-58q4-xjw5 |
| — | moodle/moodle (Packagist) | 2.9.0 to before 2.9.5 | 2.9.5 | Patch available | GHSA-fmq9-58q4-xjw5 |
| — | moodle/moodle (Packagist) | 3.0.0 to before 3.0.3 | 3.0.3 | Patch available | GHSA-fmq9-58q4-xjw5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 2.8.0 to before 2.8.11 Fixed in 2.8.11 Patch available GHSA-fmq9-58q4-xjw5
- moodle/moodle (Packagist) Vendor— Affected 2.9.0 to before 2.9.5 Fixed in 2.9.5 Patch available GHSA-fmq9-58q4-xjw5
- moodle/moodle (Packagist) Vendor— Affected 3.0.0 to before 3.0.3 Fixed in 3.0.3 Patch available GHSA-fmq9-58q4-xjw5
CPE configurations NVD · 19
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* | 2.8.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:* | 2.8.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:* | 2.8.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.3:*:*:*:*:*:*:* | 2.8.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.4:*:*:*:*:*:*:* | 2.8.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.5:*:*:*:*:*:*:* | 2.8.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.6:*:*:*:*:*:*:* | 2.8.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.7:*:*:*:*:*:*:* | 2.8.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.8:*:*:*:*:*:*:* | 2.8.8 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.9:*:*:*:*:*:*:* | 2.8.9 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:* Versions 2.8.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:* Versions 2.8.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.3:*:*:*:*:*:*:* Versions 2.8.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.4:*:*:*:*:*:*:* Versions 2.8.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.5:*:*:*:*:*:*:* Versions 2.8.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.6:*:*:*:*:*:*:* Versions 2.8.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.7:*:*:*:*:*:*:* Versions 2.8.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.8:*:*:*:*:*:*:* Versions 2.8.8 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.9:*:*:*:*:*:*:* Versions 2.8.9 Vulnerable ·Moodle
Show 9 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.8.10:*:*:*:*:*:*:* | 2.8.10 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.0:*:*:*:*:*:*:* | 2.9.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.1:*:*:*:*:*:*:* | 2.9.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.2:*:*:*:*:*:*:* | 2.9.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.3:*:*:*:*:*:*:* | 2.9.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.4:*:*:*:*:*:*:* | 2.9.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.0.0:*:*:*:*:*:*:* | 3.0.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.0.1:*:*:*:*:*:*:* | 3.0.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.0.2:*:*:*:*:*:*:* | 3.0.2 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.8.10:*:*:*:*:*:*:* Versions 2.8.10 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.0:*:*:*:*:*:*:* Versions 2.9.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.1:*:*:*:*:*:*:* Versions 2.9.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.2:*:*:*:*:*:*:* Versions 2.9.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.3:*:*:*:*:*:*:* Versions 2.9.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.4:*:*:*:*:*:*:* Versions 2.9.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.0.0:*:*:*:*:*:*:* Versions 3.0.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.0.1:*:*:*:*:*:*:* Versions 3.0.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.0.2:*:*:*:*:*:*:* Versions 3.0.2 Vulnerable ·Moodle
Remediation
- Fix · GHSA-fmq9-58q4-xjw5 moodle/moodle (Packagist) Fixed in 2.8.11 Advisory →
- Fix · GHSA-fmq9-58q4-xjw5 moodle/moodle (Packagist) Fixed in 2.9.5 Advisory →
- Fix · GHSA-fmq9-58q4-xjw5 moodle/moodle (Packagist) Fixed in 3.0.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2016-2154
- 2026-10-03 Alias added: GHSA-fmq9-58q4-xjw5
References
Advisory 2
Other 10
- [oss-security] 20160321 moodle security release
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-51167
- https://github.com/moodle/moodle/commit/214950de2a4149f0efeabf62b0978901c1c68015
- https://github.com/moodle/moodle/commit/406a0efd3720d3b9214508b2e47b8f4401061312
- https://github.com/moodle/moodle/commit/475362630ba4c5073a05b1c81caf3a7f3f373cd1
- https://github.com/moodle/moodle/commit/4e5732e7fe0e9363618039d434cb5b774a8772b0
- https://github.com/moodle/moodle/commit/89b97390d0bedd2567d61723f76caa222026d5fb
- https://github.com/moodle/moodle/commit/ff7bacf32bbe148a7ab6db3b5fa69e106e54d6a4
- https://github.com/moodle/moodle
- https://web.archive.org/web/20160424224349/http://www.securitytracker.com/id/1035333
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2016-2154 · CVE Program
- CVE-2016-2154 · NVD
- FIRST EPSS
- GHSA-fmq9-58q4-xjw5 · GitHub Advisory Database · CC BY 4.0
- CVE-2016-2154 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences