The grade-reporting feature in Singleview (aka Single View) in Moodle 2.8.x before…
Priority LOW 23CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
The grade-reporting feature in Singleview (aka Single View) in Moodle 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does not consider the moodle/grade:manage capability, which allows remote authenticated users to modify "Exclude grade" settings by leveraging the Non-Editing Instructor role.
Why it matters now
EPSS 0.01614 76th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.8.11, 2.9.5, 3.0.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 2.8.0 to before 2.8.11 | 2.8.11 | Patch available | GHSA-32hg-73hp-vwc8 |
| — | moodle/moodle (Packagist) | 2.9.0 to before 2.9.5 | 2.9.5 | Patch available | GHSA-32hg-73hp-vwc8 |
| — | moodle/moodle (Packagist) | 3.0.0 to before 3.0.3 | 3.0.3 | Patch available | GHSA-32hg-73hp-vwc8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 2.8.0 to before 2.8.11 Fixed in 2.8.11 Patch available GHSA-32hg-73hp-vwc8
- moodle/moodle (Packagist) Vendor— Affected 2.9.0 to before 2.9.5 Fixed in 2.9.5 Patch available GHSA-32hg-73hp-vwc8
- moodle/moodle (Packagist) Vendor— Affected 3.0.0 to before 3.0.3 Fixed in 3.0.3 Patch available GHSA-32hg-73hp-vwc8
CPE configurations NVD · 19
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* | 2.8.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:* | 2.8.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:* | 2.8.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.3:*:*:*:*:*:*:* | 2.8.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.4:*:*:*:*:*:*:* | 2.8.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.5:*:*:*:*:*:*:* | 2.8.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.6:*:*:*:*:*:*:* | 2.8.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.7:*:*:*:*:*:*:* | 2.8.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.8:*:*:*:*:*:*:* | 2.8.8 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.9:*:*:*:*:*:*:* | 2.8.9 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:* Versions 2.8.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:* Versions 2.8.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.3:*:*:*:*:*:*:* Versions 2.8.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.4:*:*:*:*:*:*:* Versions 2.8.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.5:*:*:*:*:*:*:* Versions 2.8.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.6:*:*:*:*:*:*:* Versions 2.8.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.7:*:*:*:*:*:*:* Versions 2.8.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.8:*:*:*:*:*:*:* Versions 2.8.8 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.9:*:*:*:*:*:*:* Versions 2.8.9 Vulnerable ·Moodle
Show 9 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.8.10:*:*:*:*:*:*:* | 2.8.10 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.0:*:*:*:*:*:*:* | 2.9.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.1:*:*:*:*:*:*:* | 2.9.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.2:*:*:*:*:*:*:* | 2.9.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.3:*:*:*:*:*:*:* | 2.9.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.4:*:*:*:*:*:*:* | 2.9.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.0.0:*:*:*:*:*:*:* | 3.0.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.0.1:*:*:*:*:*:*:* | 3.0.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.0.2:*:*:*:*:*:*:* | 3.0.2 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.8.10:*:*:*:*:*:*:* Versions 2.8.10 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.0:*:*:*:*:*:*:* Versions 2.9.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.1:*:*:*:*:*:*:* Versions 2.9.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.2:*:*:*:*:*:*:* Versions 2.9.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.3:*:*:*:*:*:*:* Versions 2.9.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.4:*:*:*:*:*:*:* Versions 2.9.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.0.0:*:*:*:*:*:*:* Versions 3.0.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.0.1:*:*:*:*:*:*:* Versions 3.0.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.0.2:*:*:*:*:*:*:* Versions 3.0.2 Vulnerable ·Moodle
Remediation
- Fix · GHSA-32hg-73hp-vwc8 moodle/moodle (Packagist) Fixed in 2.8.11 Advisory →
- Fix · GHSA-32hg-73hp-vwc8 moodle/moodle (Packagist) Fixed in 2.9.5 Advisory →
- Fix · GHSA-32hg-73hp-vwc8 moodle/moodle (Packagist) Fixed in 3.0.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2016-2155
- 2026-10-03 Alias added: GHSA-32hg-73hp-vwc8
References
Advisory 2
Other 11
- [oss-security] 20160321 moodle security release
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-52378
- https://github.com/moodle/moodle/commit/3328dc32a75d6aa4bc92865fa236dc6d52dcb7bf
- https://github.com/moodle/moodle/commit/5208032b23b7999d7048a3da7a4b70c038d93506
- https://github.com/moodle/moodle/commit/71beedee8c82c378ed10a0569c8b19ec641df9e3
- https://github.com/moodle/moodle/commit/ad67b7eeea4abf194eb432d5958e9a7032ee2c25
- https://github.com/moodle/moodle/commit/ae66ed23b6ae8000efd4e1f612697892c9795c65
- https://github.com/moodle/moodle/commit/b74d0f8404651d9ad0d97fd7eb58a94079342eb3
- https://github.com/moodle/moodle/commit/c7f7b18adecb4a80c4f3defee31e72e591133693
- https://github.com/moodle/moodle
- https://web.archive.org/web/20160424224349/http://www.securitytracker.com/id/1035333
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2016-2155 · CVE Program
- CVE-2016-2155 · NVD
- FIRST EPSS
- GHSA-32hg-73hp-vwc8 · GitHub Advisory Database · CC BY 4.0
- CVE-2016-2155 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences