Symfony before 2.8.6 and 3.x before 3.0.6 allows remote attackers to bypass…
Priority MEDIUM 49CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
Symfony before 2.8.6 and 3.x before 3.0.6 allows remote attackers to bypass authentication by logging in with an empty password and valid username, which triggers an unauthenticated bind.
Why it matters now
EPSS 0.04287 91st percentileScored 2026-11-07
Fix Fixed symfony/security-core (Packagist): 2.8.6, 3.0.6symfony/security (Packagist): 2.8.6, 3.0.6+1 more product
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | symfony/security-core (Packagist) | 2.8.0 to before 2.8.6 | 2.8.6 | Patch available | GHSA-wvj5-r78r-hhfq |
| — | symfony/security-core (Packagist) | 3.0.0 to before 3.0.6 | 3.0.6 | Patch available | GHSA-wvj5-r78r-hhfq |
| — | symfony/security (Packagist) | 2.8.0 to before 2.8.6 | 2.8.6 | Patch available | GHSA-wvj5-r78r-hhfq |
| — | symfony/security (Packagist) | 3.0.0 to before 3.0.6 | 3.0.6 | Patch available | GHSA-wvj5-r78r-hhfq |
| — | symfony/symfony (Packagist) | 2.8.0 to before 2.8.6 | 2.8.6 | Patch available | GHSA-wvj5-r78r-hhfq |
| — | symfony/symfony (Packagist) | 3.0.0 to before 3.0.6 | 3.0.6 | Patch available | GHSA-wvj5-r78r-hhfq |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- symfony/security-core (Packagist) Vendor— Affected 2.8.0 to before 2.8.6 Fixed in 2.8.6 Patch available GHSA-wvj5-r78r-hhfq
- symfony/security-core (Packagist) Vendor— Affected 3.0.0 to before 3.0.6 Fixed in 3.0.6 Patch available GHSA-wvj5-r78r-hhfq
- symfony/security (Packagist) Vendor— Affected 2.8.0 to before 2.8.6 Fixed in 2.8.6 Patch available GHSA-wvj5-r78r-hhfq
- symfony/security (Packagist) Vendor— Affected 3.0.0 to before 3.0.6 Fixed in 3.0.6 Patch available GHSA-wvj5-r78r-hhfq
- symfony/symfony (Packagist) Vendor— Affected 2.8.0 to before 2.8.6 Fixed in 2.8.6 Patch available GHSA-wvj5-r78r-hhfq
- symfony/symfony (Packagist) Vendor— Affected 3.0.0 to before 3.0.6 Fixed in 3.0.6 Patch available GHSA-wvj5-r78r-hhfq
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sensiolabs:symfony:2.8.0:*:*:*:*:*:*:* | 2.8.0 | Vulnerable | sensiolabs |
| cpe:2.3:a:sensiolabs:symfony:2.8.1:*:*:*:*:*:*:* | 2.8.1 | Vulnerable | sensiolabs |
| cpe:2.3:a:sensiolabs:symfony:2.8.2:*:*:*:*:*:*:* | 2.8.2 | Vulnerable | sensiolabs |
| cpe:2.3:a:sensiolabs:symfony:2.8.3:*:*:*:*:*:*:* | 2.8.3 | Vulnerable | sensiolabs |
| cpe:2.3:a:sensiolabs:symfony:2.8.4:*:*:*:*:*:*:* | 2.8.4 | Vulnerable | sensiolabs |
| cpe:2.3:a:sensiolabs:symfony:2.8.5:*:*:*:*:*:*:* | 2.8.5 | Vulnerable | sensiolabs |
| cpe:2.3:a:sensiolabs:symfony:3.0.0:*:*:*:*:*:*:* | 3.0.0 | Vulnerable | sensiolabs |
| cpe:2.3:a:sensiolabs:symfony:3.0.1:*:*:*:*:*:*:* | 3.0.1 | Vulnerable | sensiolabs |
| cpe:2.3:a:sensiolabs:symfony:3.0.2:*:*:*:*:*:*:* | 3.0.2 | Vulnerable | sensiolabs |
| cpe:2.3:a:sensiolabs:symfony:3.0.3:*:*:*:*:*:*:* | 3.0.3 | Vulnerable | sensiolabs |
- cpe:2.3:a:sensiolabs:symfony:2.8.0:*:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·sensiolabs
- cpe:2.3:a:sensiolabs:symfony:2.8.1:*:*:*:*:*:*:* Versions 2.8.1 Vulnerable ·sensiolabs
- cpe:2.3:a:sensiolabs:symfony:2.8.2:*:*:*:*:*:*:* Versions 2.8.2 Vulnerable ·sensiolabs
- cpe:2.3:a:sensiolabs:symfony:2.8.3:*:*:*:*:*:*:* Versions 2.8.3 Vulnerable ·sensiolabs
- cpe:2.3:a:sensiolabs:symfony:2.8.4:*:*:*:*:*:*:* Versions 2.8.4 Vulnerable ·sensiolabs
- cpe:2.3:a:sensiolabs:symfony:2.8.5:*:*:*:*:*:*:* Versions 2.8.5 Vulnerable ·sensiolabs
- cpe:2.3:a:sensiolabs:symfony:3.0.0:*:*:*:*:*:*:* Versions 3.0.0 Vulnerable ·sensiolabs
- cpe:2.3:a:sensiolabs:symfony:3.0.1:*:*:*:*:*:*:* Versions 3.0.1 Vulnerable ·sensiolabs
- cpe:2.3:a:sensiolabs:symfony:3.0.2:*:*:*:*:*:*:* Versions 3.0.2 Vulnerable ·sensiolabs
- cpe:2.3:a:sensiolabs:symfony:3.0.3:*:*:*:*:*:*:* Versions 3.0.3 Vulnerable ·sensiolabs
Show 2 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sensiolabs:symfony:3.0.4:*:*:*:*:*:*:* | 3.0.4 | Vulnerable | sensiolabs |
| cpe:2.3:a:sensiolabs:symfony:3.0.5:*:*:*:*:*:*:* | 3.0.5 | Vulnerable | sensiolabs |
- cpe:2.3:a:sensiolabs:symfony:3.0.4:*:*:*:*:*:*:* Versions 3.0.4 Vulnerable ·sensiolabs
- cpe:2.3:a:sensiolabs:symfony:3.0.5:*:*:*:*:*:*:* Versions 3.0.5 Vulnerable ·sensiolabs
Remediation
- Fix · GHSA-wvj5-r78r-hhfq symfony/security-core (Packagist) Fixed in 2.8.6 Advisory →
- Fix · GHSA-wvj5-r78r-hhfq symfony/security-core (Packagist) Fixed in 3.0.6 Advisory →
- Fix · GHSA-wvj5-r78r-hhfq symfony/security (Packagist) Fixed in 2.8.6 Advisory →
- Fix · GHSA-wvj5-r78r-hhfq symfony/security (Packagist) Fixed in 3.0.6 Advisory →
- Fix · GHSA-wvj5-r78r-hhfq symfony/symfony (Packagist) Fixed in 2.8.6 Advisory →
- Fix · GHSA-wvj5-r78r-hhfq symfony/symfony (Packagist) Fixed in 3.0.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-2403
- 2026-10-03 Alias added: GHSA-wvj5-r78r-hhfq
- 2026-10-18 EPSS moved to the 90th–95th percentile
References
Advisory 3
Other 5
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/security-core/CVE-2016-2403.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/security/CVE-2016-2403.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2016-2403.yaml
- https://symfony.com/cve-2016-2403
- https://web.archive.org/web/20210123224944/http://www.securityfocus.com/bid/96137
More sensiolabs Symfony vulnerabilities
- TI-2019-13616 An issue was discovered in Symfony 3.4.0 through 3.4.34, 4.2.0 through 4.2.11, and 4.3.0… CVSS 3.1CRITICAL 9.8
- TI-2018-10604 An issue was discovered in Http Foundation in Symfony 2.7.0 through 2.7.48, 2.8.0 through… CVSS 3.1MEDIUM 6.5
- TI-2019-08131 In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and… CVSS 3.1CRITICAL 9.8
- TI-2019-08459 An issue was discovered in Symfony before 4.2.12 and 4.3.x before 4.3.8. CVSS 3.1CRITICAL 9.8
- TI-2018-08136 An issue was discovered in the Ldap component in Symfony 2.8.x before 2.8.37, 3.3.x… CVSS 3.0CRITICAL 9.8
- TI-2019-08134 In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2016-2403 · CVE Program
- CVE-2016-2403 · NVD
- FIRST EPSS
- GHSA-wvj5-r78r-hhfq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences