In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and…
Priority MEDIUM 46CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting, SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79 and CWE-89.
Summary
In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, HTTP Methods provided as verbs or using the override header may be treated as trusted input, but they are not validated, possibly causing SQL injection or XSS. This is related to symfony/http-foundation.
Why it matters now
EPSS 0.01871 79th percentileScored 2026-11-07
Fix Fixed symfony/http-foundation (Packagist): 2.7.51, 2.8.50, 3.4.26 +2symfony/symfony (Packagist): 2.7.51, 2.8.50, 3.4.26 +2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | symfony/http-foundation (Packagist) | 2.7.0 to before 2.7.51 | 2.7.51 | Patch available | GHSA-x92h-wmg2-6hp7 |
| — | symfony/http-foundation (Packagist) | 2.8.0 to before 2.8.50 | 2.8.50 | Patch available | GHSA-x92h-wmg2-6hp7 |
| — | symfony/http-foundation (Packagist) | 3.0.0 to before 3.4.26 | 3.4.26 | Patch available | GHSA-x92h-wmg2-6hp7 |
| — | symfony/http-foundation (Packagist) | 4.0.0 to before 4.1.12 | 4.1.12 | Patch available | GHSA-x92h-wmg2-6hp7 |
| — | symfony/http-foundation (Packagist) | 4.2.0 to before 4.2.7 | 4.2.7 | Patch available | GHSA-x92h-wmg2-6hp7 |
| — | symfony/symfony (Packagist) | 2.7.0 to before 2.7.51 | 2.7.51 | Patch available | GHSA-x92h-wmg2-6hp7 |
| — | symfony/symfony (Packagist) | 2.8.0 to before 2.8.50 | 2.8.50 | Patch available | GHSA-x92h-wmg2-6hp7 |
| — | symfony/symfony (Packagist) | 3.0.0 to before 3.4.26 | 3.4.26 | Patch available | GHSA-x92h-wmg2-6hp7 |
| — | symfony/symfony (Packagist) | 4.0.0 to before 4.1.12 | 4.1.12 | Patch available | GHSA-x92h-wmg2-6hp7 |
| — | symfony/symfony (Packagist) | 4.2.0 to before 4.2.7 | 4.2.7 | Patch available | GHSA-x92h-wmg2-6hp7 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- symfony/http-foundation (Packagist) Vendor— Affected 2.7.0 to before 2.7.51 Fixed in 2.7.51 Patch available GHSA-x92h-wmg2-6hp7
- symfony/http-foundation (Packagist) Vendor— Affected 2.8.0 to before 2.8.50 Fixed in 2.8.50 Patch available GHSA-x92h-wmg2-6hp7
- symfony/http-foundation (Packagist) Vendor— Affected 3.0.0 to before 3.4.26 Fixed in 3.4.26 Patch available GHSA-x92h-wmg2-6hp7
- symfony/http-foundation (Packagist) Vendor— Affected 4.0.0 to before 4.1.12 Fixed in 4.1.12 Patch available GHSA-x92h-wmg2-6hp7
- symfony/http-foundation (Packagist) Vendor— Affected 4.2.0 to before 4.2.7 Fixed in 4.2.7 Patch available GHSA-x92h-wmg2-6hp7
- symfony/symfony (Packagist) Vendor— Affected 2.7.0 to before 2.7.51 Fixed in 2.7.51 Patch available GHSA-x92h-wmg2-6hp7
- symfony/symfony (Packagist) Vendor— Affected 2.8.0 to before 2.8.50 Fixed in 2.8.50 Patch available GHSA-x92h-wmg2-6hp7
- symfony/symfony (Packagist) Vendor— Affected 3.0.0 to before 3.4.26 Fixed in 3.4.26 Patch available GHSA-x92h-wmg2-6hp7
- symfony/symfony (Packagist) Vendor— Affected 4.0.0 to before 4.1.12 Fixed in 4.1.12 Patch available GHSA-x92h-wmg2-6hp7
- symfony/symfony (Packagist) Vendor— Affected 4.2.0 to before 4.2.7 Fixed in 4.2.7 Patch available GHSA-x92h-wmg2-6hp7
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* | 2.7.0 to before 2.7.51; 2.8.0 to before 2.8.50; 3.4.0 to before 3.4.26; 4.1.0 to before 4.1.12; 4.2.0 to before 4.2.7 | Vulnerable | sensiolabs |
- cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions 2.7.0 to before 2.7.51; 2.8.0 to before 2.8.50; 3.4.0 to before 3.4.26; 4.1.0 to before 4.1.12; 4.2.0 to before 4.2.7 Vulnerable ·sensiolabs
Remediation
- Fix · GHSA-x92h-wmg2-6hp7 symfony/http-foundation (Packagist) Fixed in 2.7.51 Advisory →
- Fix · GHSA-x92h-wmg2-6hp7 symfony/http-foundation (Packagist) Fixed in 2.8.50 Advisory →
- Fix · GHSA-x92h-wmg2-6hp7 symfony/http-foundation (Packagist) Fixed in 3.4.26 Advisory →
- Fix · GHSA-x92h-wmg2-6hp7 symfony/http-foundation (Packagist) Fixed in 4.1.12 Advisory →
- Fix · GHSA-x92h-wmg2-6hp7 symfony/http-foundation (Packagist) Fixed in 4.2.7 Advisory →
- Fix · GHSA-x92h-wmg2-6hp7 symfony/symfony (Packagist) Fixed in 2.7.51 Advisory →
- Fix · GHSA-x92h-wmg2-6hp7 symfony/symfony (Packagist) Fixed in 2.8.50 Advisory →
- Fix · GHSA-x92h-wmg2-6hp7 symfony/symfony (Packagist) Fixed in 3.4.26 Advisory →
- Fix · GHSA-x92h-wmg2-6hp7 symfony/symfony (Packagist) Fixed in 4.1.12 Advisory →
- Fix · GHSA-x92h-wmg2-6hp7 symfony/symfony (Packagist) Fixed in 4.2.7 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10913
- 2026-10-03 Alias added: GHSA-x92h-wmg2-6hp7
References
Advisory 2
More sensiolabs Symfony vulnerabilities
- TI-2019-13616 An issue was discovered in Symfony 3.4.0 through 3.4.34, 4.2.0 through 4.2.11, and 4.3.0… CVSS 3.1CRITICAL 9.8
- TI-2018-10604 An issue was discovered in Http Foundation in Symfony 2.7.0 through 2.7.48, 2.8.0 through… CVSS 3.1MEDIUM 6.5
- TI-2019-08131 In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and… CVSS 3.1CRITICAL 9.8
- TI-2016-02159 Symfony before 2.8.6 and 3.x before 3.0.6 allows remote attackers to bypass… CVSS 3.0CRITICAL 9.8
- TI-2019-08459 An issue was discovered in Symfony before 4.2.12 and 4.3.x before 4.3.8. CVSS 3.1CRITICAL 9.8
- TI-2018-08136 An issue was discovered in the Ldap component in Symfony 2.8.x before 2.8.37, 3.3.x… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2019-10913 · CVE Program
- CVE-2019-10913 · NVD
- FIRST EPSS
- GHSA-x92h-wmg2-6hp7 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-10913 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences