An issue was discovered in the Ldap component in Symfony 2.8.x before 2.8.37, 3.3.x…
Priority MEDIUM 47CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
An issue was discovered in the Ldap component in Symfony 2.8.x before 2.8.37, 3.3.x before 3.3.17, 3.4.x before 3.4.7, and 4.0.x before 4.0.7. It allows remote attackers to bypass authentication by logging in with a "null" password and valid username, which triggers an unauthenticated bind. NOTE: this issue exists because of an incomplete fix for CVE-2016-2403.
Why it matters now
EPSS 0.02366 83rd percentileScored 2026-11-07
Fix Fixed symfony/security-core (Packagist): 2.8.37, 3.3.17, 3.4.7 +1symfony/security (Packagist): 2.8.37, 3.3.17, 3.4.7 +1+1 more product
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | symfony/security-core (Packagist) | 2.8.0 to before 2.8.37 | 2.8.37 | Patch available | GHSA-35c5-28pg-2qg4 |
| — | symfony/security-core (Packagist) | 3.0.0 to before 3.3.17 | 3.3.17 | Patch available | GHSA-35c5-28pg-2qg4 |
| — | symfony/security-core (Packagist) | 3.4.0 to before 3.4.7 | 3.4.7 | Patch available | GHSA-35c5-28pg-2qg4 |
| — | symfony/security-core (Packagist) | 4.0.0 to before 4.0.7 | 4.0.7 | Patch available | GHSA-35c5-28pg-2qg4 |
| — | symfony/security (Packagist) | 2.8.0 to before 2.8.37 | 2.8.37 | Patch available | GHSA-35c5-28pg-2qg4 |
| — | symfony/security (Packagist) | 3.0.0 to before 3.3.17 | 3.3.17 | Patch available | GHSA-35c5-28pg-2qg4 |
| — | symfony/security (Packagist) | 3.4.0 to before 3.4.7 | 3.4.7 | Patch available | GHSA-35c5-28pg-2qg4 |
| — | symfony/security (Packagist) | 4.0.0 to before 4.0.7 | 4.0.7 | Patch available | GHSA-35c5-28pg-2qg4 |
| — | symfony/symfony (Packagist) | 2.8.0 to before 2.8.37 | 2.8.37 | Patch available | GHSA-35c5-28pg-2qg4 |
| — | symfony/symfony (Packagist) | 3.0.0 to before 3.3.17 | 3.3.17 | Patch available | GHSA-35c5-28pg-2qg4 |
| — | symfony/symfony (Packagist) | 3.4.0 to before 3.4.7 | 3.4.7 | Patch available | GHSA-35c5-28pg-2qg4 |
| — | symfony/symfony (Packagist) | 4.0.0 to before 4.0.7 | 4.0.7 | Patch available | GHSA-35c5-28pg-2qg4 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- symfony/security-core (Packagist) Vendor— Affected 2.8.0 to before 2.8.37 Fixed in 2.8.37 Patch available GHSA-35c5-28pg-2qg4
- symfony/security-core (Packagist) Vendor— Affected 3.0.0 to before 3.3.17 Fixed in 3.3.17 Patch available GHSA-35c5-28pg-2qg4
- symfony/security-core (Packagist) Vendor— Affected 3.4.0 to before 3.4.7 Fixed in 3.4.7 Patch available GHSA-35c5-28pg-2qg4
- symfony/security-core (Packagist) Vendor— Affected 4.0.0 to before 4.0.7 Fixed in 4.0.7 Patch available GHSA-35c5-28pg-2qg4
- symfony/security (Packagist) Vendor— Affected 2.8.0 to before 2.8.37 Fixed in 2.8.37 Patch available GHSA-35c5-28pg-2qg4
- symfony/security (Packagist) Vendor— Affected 3.0.0 to before 3.3.17 Fixed in 3.3.17 Patch available GHSA-35c5-28pg-2qg4
- symfony/security (Packagist) Vendor— Affected 3.4.0 to before 3.4.7 Fixed in 3.4.7 Patch available GHSA-35c5-28pg-2qg4
- symfony/security (Packagist) Vendor— Affected 4.0.0 to before 4.0.7 Fixed in 4.0.7 Patch available GHSA-35c5-28pg-2qg4
- symfony/symfony (Packagist) Vendor— Affected 2.8.0 to before 2.8.37 Fixed in 2.8.37 Patch available GHSA-35c5-28pg-2qg4
- symfony/symfony (Packagist) Vendor— Affected 3.0.0 to before 3.3.17 Fixed in 3.3.17 Patch available GHSA-35c5-28pg-2qg4
- symfony/symfony (Packagist) Vendor— Affected 3.4.0 to before 3.4.7 Fixed in 3.4.7 Patch available GHSA-35c5-28pg-2qg4
- symfony/symfony (Packagist) Vendor— Affected 4.0.0 to before 4.0.7 Fixed in 4.0.7 Patch available GHSA-35c5-28pg-2qg4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* | 2.8.0 to before 2.8.37; 3.3.0 to before 3.3.17; 3.4.0 to before 3.4.7; 4.0.0 to before 4.0.7 | Vulnerable | sensiolabs |
- cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions 2.8.0 to before 2.8.37; 3.3.0 to before 3.3.17; 3.4.0 to before 3.4.7; 4.0.0 to before 4.0.7 Vulnerable ·sensiolabs
Remediation
- Fix · GHSA-35c5-28pg-2qg4 symfony/security-core (Packagist) Fixed in 2.8.37 Advisory →
- Fix · GHSA-35c5-28pg-2qg4 symfony/security-core (Packagist) Fixed in 3.3.17 Advisory →
- Fix · GHSA-35c5-28pg-2qg4 symfony/security-core (Packagist) Fixed in 3.4.7 Advisory →
- Fix · GHSA-35c5-28pg-2qg4 symfony/security-core (Packagist) Fixed in 4.0.7 Advisory →
- Fix · GHSA-35c5-28pg-2qg4 symfony/security (Packagist) Fixed in 2.8.37 Advisory →
- Fix · GHSA-35c5-28pg-2qg4 symfony/security (Packagist) Fixed in 3.3.17 Advisory →
- Fix · GHSA-35c5-28pg-2qg4 symfony/security (Packagist) Fixed in 3.4.7 Advisory →
- Fix · GHSA-35c5-28pg-2qg4 symfony/security (Packagist) Fixed in 4.0.7 Advisory →
- Fix · GHSA-35c5-28pg-2qg4 symfony/symfony (Packagist) Fixed in 2.8.37 Advisory →
- Fix · GHSA-35c5-28pg-2qg4 symfony/symfony (Packagist) Fixed in 3.3.17 Advisory →
- Fix · GHSA-35c5-28pg-2qg4 symfony/symfony (Packagist) Fixed in 3.4.7 Advisory →
- Fix · GHSA-35c5-28pg-2qg4 symfony/symfony (Packagist) Fixed in 4.0.7 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2018-11407
- 2026-10-03 Alias added: GHSA-35c5-28pg-2qg4
References
Advisory 2
Other 7
- https://github.com/symfony/symfony/pull/27377
- https://github.com/symfony/symfony/commit/b46fc93785d37ffa5d706a82cd175b33ce8f2934
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/security-core/CVE-2018-11407.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/security/CVE-2018-11407.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2018-11407.yaml
- https://github.com/symfony/symfony
- https://symfony.com/cve-2018-11407
More sensiolabs Symfony vulnerabilities
- TI-2019-13616 An issue was discovered in Symfony 3.4.0 through 3.4.34, 4.2.0 through 4.2.11, and 4.3.0… CVSS 3.1CRITICAL 9.8
- TI-2018-10604 An issue was discovered in Http Foundation in Symfony 2.7.0 through 2.7.48, 2.8.0 through… CVSS 3.1MEDIUM 6.5
- TI-2019-08131 In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and… CVSS 3.1CRITICAL 9.8
- TI-2016-02159 Symfony before 2.8.6 and 3.x before 3.0.6 allows remote attackers to bypass… CVSS 3.0CRITICAL 9.8
- TI-2019-08459 An issue was discovered in Symfony before 4.2.12 and 4.3.x before 4.3.8. CVSS 3.1CRITICAL 9.8
- TI-2019-08134 In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2018-11407 · CVE Program
- CVE-2018-11407 · NVD
- FIRST EPSS
- GHSA-35c5-28pg-2qg4 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-11407 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences