Read the docs

Puppet

Records130All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical19CVSS 9.0–10.0
CVSS high30CVSS 7.0–8.9

Exploited now

Puppet records in CISA KEV

No Puppet vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

42 records in Puppet · all components

Priority MEDIUM 47

Puppet Server before 2.3.2 and Ruby puppetmaster in Puppet 4.x before 4.4.2 and in Puppet Agent before 1.4.2 might allow remote attackers to bypass intended auth.conf access restrictions by leveraging incorrect URL decod…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.02889 Published 2016-06-10 Partial fix · 4.4.2 CWE-284
Priority MEDIUM 47

The (1) template and (2) inline_template functions in the master server in Puppet before 2.6.18, 2.7.x before 2.7.21, and 3.1.x before 3.1.1, and Puppet Enterprise before 1.2.7 and 2.7.x before 2.7.2 allows remote authen…

CVSS 2.0HIGH 9.0 Network Low privileges Interaction — EPSS 0.04927 Published 2013-03-20 Partial fix
TI-2021-08594 CVE-2021-27021 · GHSA-j664-pgf6-rhhh

SQL injection in Puppet DB

Priority MEDIUM 41

A flaw was discovered in Puppet DB, this flaw results in an escalation of privileges which allows the user to delete tables via an SQL query.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.01262 Published 2021-07-20 No fix listed CWE-1027
Priority MEDIUM 41

Versions of Puppet prior to 4.10.1 will deserialize data off the wire (from the agent to the server, in this case) with a attacker-specified format.

CVSS 3.0HIGH 8.2 Network Low privileges No interaction EPSS 0.02762 Published 2017-07-05 Partial fix CWE-502
Priority MEDIUM 40

Puppet Enterprise 2016.4.x prior to 2016.4.12, Puppet Enterprise 2017.3.x prior to 2017.3.7, Puppet Enterprise 2018.1.x prior to 2018.1.1, Puppet Agent 1.10.x prior to 1.10.13, Puppet Agent 5.3.x prior to 5.3.7, and Pupp…

CVSS 3.0HIGH 8.8 Network Low privileges No interaction EPSS 0.01117 Published 2018-06-11 No fix listed CWE-426
Priority MEDIUM 40

Puppet before 2.6.18, 2.7.x before 2.7.21, and 3.1.x before 3.1.1, and Puppet Enterprise before 1.2.7 and 2.7.x before 2.7.2, when listening for incoming connections is enabled and allowing access to the "run" REST endpo…

CVSS 2.0HIGH 7.1 Network Low privileges Interaction — EPSS 0.05375 Published 2013-03-20 No fix listed
Priority LOW 39

Puppet 2.7.x before 2.7.22 and 3.2.x before 3.2.2, and Puppet Enterprise before 2.8.2, deserializes untrusted YAML, which allows remote attackers to instantiate arbitrary Ruby classes and execute arbitrary code via a cra…

CVSS 2.0HIGH 7.5 Network No auth Interaction — EPSS 0.03408 Published 2013-08-19 Partial fix · 2.7.22, 3.2.2 CWE-20
TI-2018-04795 CVE-2018-6515 · GHSA-5xw6-x436-6c39

Improper input validation in Puppet Agent

Priority LOW 36

Puppet Agent 1.10.x prior to 1.10.13, Puppet Agent 5.3.x prior to 5.3.7, and Puppet Agent 5.5.x prior to 5.5.2 on Windows only, with a specially crafted configuration file an attacker could get pxp-agent to load arbitrar…

CVSS 3.0HIGH 7.8 Local No auth User interaction EPSS 0.00847 Published 2018-06-11 No fix listed CWE-20
TI-2018-04794 CVE-2018-6514 · GHSA-w26j-rr99-hqph

Untrusted search path in Puppet Agent

Priority LOW 36

In Puppet Agent 1.10.x prior to 1.10.13, Puppet Agent 5.3.x prior to 5.3.7, Puppet Agent 5.5.x prior to 5.5.2, Facter on Windows is vulnerable to a DLL preloading attack, which could lead to a privilege escalation.

CVSS 3.0HIGH 7.8 Local No auth User interaction EPSS 0.00847 Published 2018-06-11 No fix listed CWE-426
Priority LOW 34

Puppet 2.6.x before 2.6.18 and Puppet Enterprise 1.2.x before 1.2.7 allows remote authenticated users to execute arbitrary code on the puppet master, or an agent with puppet kick enabled, via a crafted request for a repo…

CVSS 2.0MEDIUM 6.5 Network Low privileges Interaction — EPSS 0.02912 Published 2013-03-20 Partial fix
Priority LOW 32

Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows remote authenticated users with agent SSL keys and file-creation permissions on t…

CVSS 2.0MEDIUM 6.0 Network Low privileges Interaction — EPSS 0.02602 Published 2012-05-29 Partial fix · 2.6.15, 2.7.13 CWE-78
Priority LOW 31

In previous versions of Puppet Agent it was possible for the agent to retrieve facts from an environment that it was not classified to retrieve from.

CVSS 3.0MEDIUM 6.5 Network Low privileges No interaction EPSS 0.01 Published 2018-02-09 Fixed in 2017.3.4, 5.3.4 CWE-269
Priority LOW 31

The default vhost configuration file in Puppet before 3.6.2 does not include the SSLCARevocationCheck directive, which might allow remote attackers to obtain sensitive information via a revoked certificate when a Puppet…

CVSS 3.0MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00894 Published 2017-12-11 No fix listed CWE-295
Priority LOW 31

The change_user method in the SUIDManager (lib/puppet/util/suidmanager.rb) in Puppet 2.6.x before 2.6.14 and 2.7.x before 2.7.11, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x before 2.0.3 does not properly man…

CVSS 2.0MEDIUM 6.9 Local No auth Interaction — EPSS 0.00384 Published 2012-05-29 Partial fix · 2.6.14, 2.7.11 CWE-264
TI-2020-06423 CVE-2020-7942 · GHSA-gqvf-892r-vjm5

Improper certificate validation in Puppet

Priority LOW 30

Previously, Puppet operated on a model that a node with a valid certificate was entitled to all information in the system and that a compromised certificate allowed access to everything in the infrastructure.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00801 Published 2020-02-19 Partial fix · 5.5.19, 6.13.0 CWE-295
Priority LOW 28

Untrusted search path vulnerability in Puppet Enterprise 2.8 before 2.8.7, Puppet before 2.7.26 and 3.x before 3.6.2, Facter 1.6.x and 2.x before 2.0.2, Hiera before 1.3.4, and Mcollective before 2.5.2, when running with…

CVSS 2.0MEDIUM 6.2 Local No auth Interaction — EPSS 0.00542 Published 2014-11-16 Partial fix · 1.7.6, 2.0.2 +4 CWE-17
Priority LOW 28

Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x, when running in --edit mode, uses a predictable file name, which allows local users to run arbitrary Puppet code or trick a user into editing arbitrary files.

CVSS 2.0MEDIUM 6.2 Local No auth Interaction — EPSS 0.00338 Published 2011-10-27 Partial fix · 2.7.5, 2.6.11 CWE-264
Priority LOW 27

Unspecified vulnerability in Puppet 2.7.x before 2.7.23 and 3.2.x before 3.2.4, and Puppet Enterprise 2.8.x before 2.8.3 and 3.0.x before 3.0.1, allows remote attackers to execute arbitrary Ruby programs from the master…

CVSS 2.0MEDIUM 5.1 Network No auth Interaction — EPSS 0.01643 Published 2013-08-20 Partial fix · 2.7.23, 3.2.4
Priority LOW 26

Puppet before 2.6.18, 2.7.x before 2.7.21, and 3.1.x before 3.1.1, and Puppet Enterprise before 1.2.7 and 2.7.x before 2.7.2 allows remote authenticated users with a valid certificate and private key to read arbitrary ca…

CVSS 2.0MEDIUM 4.9 Network Low privileges Interaction — EPSS 0.01859 Published 2013-03-20 Partial fix CWE-264
Load more
Open these records in search →