Read the docs
TI-2016-03932 Aliases CVE-2016-4567GHSA-277w-qpxr-2549

Cross-site scripting (XSS) vulnerability in flash/FlashMediaElement.as in MediaElement.js…

Priority LOW 37CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Cross-site scripting (XSS) vulnerability in flash/FlashMediaElement.as in MediaElement.js before 2.21.0, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via an obfuscated form of the jsinitfunction parameter, as demonstrated by "jsinitfunctio%gn."

Why it matters now

EPSS 0.07351 94th percentileScored 2026-11-07
Fix Fixed mediaelement (npm): 2.11.1contao-components/mediaelement (Packagist): 2.21.1+1 more product

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—mediaelement (npm)before 2.11.12.11.1Patch availableGHSA-277w-qpxr-2549
—contao-components/mediaelement (Packagist)2.14.2 to before 2.21.12.21.1Patch availableGHSA-277w-qpxr-2549
—contao/core (Packagist)3.0.0 to before 3.5.153.5.15Patch availableGHSA-277w-qpxr-2549
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • mediaelement (npm) Vendor— Affected before 2.11.1 Fixed in 2.11.1 Patch available GHSA-277w-qpxr-2549
  • contao-components/mediaelement (Packagist) Vendor— Affected 2.14.2 to before 2.21.1 Fixed in 2.21.1 Patch available GHSA-277w-qpxr-2549
  • contao/core (Packagist) Vendor— Affected 3.0.0 to before 3.5.15 Fixed in 3.5.15 Patch available GHSA-277w-qpxr-2549

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:mediaelementjs:mediaelement.js:*:*:*:*:*:*:*:*up to 2.20.1VulnerableMediaelementjs
cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*up to 4.5.1VulnerableWordPress
  • cpe:2.3:a:mediaelementjs:mediaelement.js:*:*:*:*:*:*:*:* Versions up to 2.20.1 Vulnerable ·Mediaelementjs
  • cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* Versions up to 4.5.1 Vulnerable ·WordPress

Remediation

  • Fix · GHSA-277w-qpxr-2549 mediaelement (npm) Fixed in 2.11.1 Advisory →
  • Fix · GHSA-277w-qpxr-2549 contao-components/mediaelement (Packagist) Fixed in 2.21.1 Advisory →
  • Fix · GHSA-277w-qpxr-2549 contao/core (Packagist) Fixed in 3.5.15 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-4567
  2. 2026-10-03 Alias added: GHSA-277w-qpxr-2549

References

Sources