Apache Ambari 2.x before 2.4.0 includes KDC administrator passwords on the kadmin command…
Priority LOW 25CWE-200Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Apache Ambari 2.x before 2.4.0 includes KDC administrator passwords on the kadmin command line, which allows local users to obtain sensitive information via a process listing.
Why it matters now
EPSS 0.00513 44th percentileScored 2026-11-07
Fix Fixed org.apache.ambari:ambari (Maven): 2.4.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.ambari:ambari (Maven) | 2.0.0 to before 2.4.0 | 2.4.0 | Patch available | GHSA-q3pw-6vf2-66hf |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.ambari:ambari (Maven) Vendor— Affected 2.0.0 to before 2.4.0 Fixed in 2.4.0 Patch available GHSA-q3pw-6vf2-66hf
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:ambari:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:ambari:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:ambari:2.0.2:*:*:*:*:*:*:* | 2.0.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:ambari:2.1.0:*:*:*:*:*:*:* | 2.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:ambari:2.1.1:*:*:*:*:*:*:* | 2.1.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:ambari:2.1.2:*:*:*:*:*:*:* | 2.1.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:ambari:2.2.0:*:*:*:*:*:*:* | 2.2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:ambari:2.2.1:*:*:*:*:*:*:* | 2.2.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:ambari:2.2.2:*:*:*:*:*:*:* | 2.2.2 | Vulnerable | Apache |
- cpe:2.3:a:apache:ambari:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:ambari:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Apache
- cpe:2.3:a:apache:ambari:2.0.2:*:*:*:*:*:*:* Versions 2.0.2 Vulnerable ·Apache
- cpe:2.3:a:apache:ambari:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:ambari:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·Apache
- cpe:2.3:a:apache:ambari:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·Apache
- cpe:2.3:a:apache:ambari:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:ambari:2.2.1:*:*:*:*:*:*:* Versions 2.2.1 Vulnerable ·Apache
- cpe:2.3:a:apache:ambari:2.2.2:*:*:*:*:*:*:* Versions 2.2.2 Vulnerable ·Apache
Remediation
- Fix · GHSA-q3pw-6vf2-66hf org.apache.ambari:ambari (Maven) Fixed in 2.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-4976
- 2026-10-03 Alias added: GHSA-q3pw-6vf2-66hf
References
More Apache Ambari vulnerabilities
- TI-2016-05848 Improper access control in Apache Ambari CVSS 3.0CRITICAL 9.8
- TI-2017-03642 During installation of Ambari 2.4.0 through 2.4.2, Ambari Server artifacts are not created with proper ACLs. CVSS 3.0CRITICAL 9.8
- TI-2014-02906 In Ambari 1.2.0 through 2.2.2, it may be possible to execute arbitrary system commands on… CVSS 3.0CRITICAL 9.8
- TI-2025-16981 Apache Ambari: Code Injection Vulnerability in Ambari Alert Definition CVSS 3.1HIGH 8.8
- TI-2024-34845 Apache Ambari: Remote Code Injection in Ambari Metrics and AMS Alerts CVSS 3.1HIGH 8.8
- TI-2023-27565 Apache Ambari: authenticated users could perform command injection to perform RCE CVSS 3.1HIGH 8.8
Sources
- CVE-2016-4976 · CVE Program
- CVE-2016-4976 · NVD
- FIRST EPSS
- GHSA-q3pw-6vf2-66hf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences