In Moodle 3.x, glossary search displays entries without checking user permissions to view them.
Priority LOW 26CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
In Moodle 3.x, glossary search displays entries without checking user permissions to view them.
Why it matters now
EPSS 0.01098 65th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.1 to before 3.1.1 | 3.1.1 | Patch available | GHSA-g58x-p3pj-rg52 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.1 to before 3.1.1 Fixed in 3.1.1 Patch available GHSA-g58x-p3pj-rg52
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:3.1.0:*:*:*:*:*:*:* | 3.1.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.1.0:beta:*:*:*:*:*:* | 3.1.0 beta | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.1.0:rc1:*:*:*:*:*:* | 3.1.0 rc1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.1.0:rc2:*:*:*:*:*:* | 3.1.0 rc2 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:3.1.0:*:*:*:*:*:*:* Versions 3.1.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.1.0:beta:*:*:*:*:*:* Versions 3.1.0 beta Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.1.0:rc1:*:*:*:*:*:* Versions 3.1.0 rc1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.1.0:rc2:*:*:*:*:*:* Versions 3.1.0 rc2 Vulnerable ·Moodle
Remediation
- Fix · GHSA-g58x-p3pj-rg52 moodle/moodle (Packagist) Fixed in 3.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-5012
- 2026-10-03 Alias added: GHSA-g58x-p3pj-rg52
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2016-5012 · CVE Program
- CVE-2016-5012 · NVD
- FIRST EPSS
- GHSA-g58x-p3pj-rg52 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences