In Moodle 2.x and 3.x, an unenrolled user still receives event monitor notifications even…
Priority LOW 26CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
In Moodle 2.x and 3.x, an unenrolled user still receives event monitor notifications even though they can no longer access the course.
Why it matters now
EPSS 0.00977 62nd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.1.1, 3.0.5, 2.9.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.1.0 to before 3.1.1 | 3.1.1 | Patch available | GHSA-c4cq-v4wp-28hg |
| — | moodle/moodle (Packagist) | 3.0.0 to before 3.0.5 | 3.0.5 | Patch available | GHSA-c4cq-v4wp-28hg |
| — | moodle/moodle (Packagist) | 2.9.0 to before 2.9.7 | 2.9.7 | Patch available | GHSA-c4cq-v4wp-28hg |
| — | moodle/moodle (Packagist) | 2.8.0 – 2.8.12 | — | No fix listed | GHSA-c4cq-v4wp-28hg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.1.0 to before 3.1.1 Fixed in 3.1.1 Patch available GHSA-c4cq-v4wp-28hg
- moodle/moodle (Packagist) Vendor— Affected 3.0.0 to before 3.0.5 Fixed in 3.0.5 Patch available GHSA-c4cq-v4wp-28hg
- moodle/moodle (Packagist) Vendor— Affected 2.9.0 to before 2.9.7 Fixed in 2.9.7 Patch available GHSA-c4cq-v4wp-28hg
- moodle/moodle (Packagist) Vendor— Affected 2.8.0 – 2.8.12 Fixed in — No fix listed GHSA-c4cq-v4wp-28hg
CPE configurations NVD · 26
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* | 2.8.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:* | 2.8.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:* | 2.8.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.3:*:*:*:*:*:*:* | 2.8.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.4:*:*:*:*:*:*:* | 2.8.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.5:*:*:*:*:*:*:* | 2.8.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.6:*:*:*:*:*:*:* | 2.8.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.7:*:*:*:*:*:*:* | 2.8.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.8:*:*:*:*:*:*:* | 2.8.8 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.9:*:*:*:*:*:*:* | 2.8.9 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:* Versions 2.8.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:* Versions 2.8.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.3:*:*:*:*:*:*:* Versions 2.8.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.4:*:*:*:*:*:*:* Versions 2.8.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.5:*:*:*:*:*:*:* Versions 2.8.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.6:*:*:*:*:*:*:* Versions 2.8.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.7:*:*:*:*:*:*:* Versions 2.8.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.8:*:*:*:*:*:*:* Versions 2.8.8 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.9:*:*:*:*:*:*:* Versions 2.8.9 Vulnerable ·Moodle
Show 16 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.8.10:*:*:*:*:*:*:* | 2.8.10 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.11:*:*:*:*:*:*:* | 2.8.11 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.12:*:*:*:*:*:*:* | 2.8.12 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.0:*:*:*:*:*:*:* | 2.9.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.1:*:*:*:*:*:*:* | 2.9.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.2:*:*:*:*:*:*:* | 2.9.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.3:*:*:*:*:*:*:* | 2.9.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.4:*:*:*:*:*:*:* | 2.9.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.5:*:*:*:*:*:*:* | 2.9.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.6:*:*:*:*:*:*:* | 2.9.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.0.0:*:*:*:*:*:*:* | 3.0.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.0.1:*:*:*:*:*:*:* | 3.0.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.0.2:*:*:*:*:*:*:* | 3.0.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.0.3:*:*:*:*:*:*:* | 3.0.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.0.4:*:*:*:*:*:*:* | 3.0.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.1.0:*:*:*:*:*:*:* | 3.1.0 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.8.10:*:*:*:*:*:*:* Versions 2.8.10 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.11:*:*:*:*:*:*:* Versions 2.8.11 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.12:*:*:*:*:*:*:* Versions 2.8.12 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.0:*:*:*:*:*:*:* Versions 2.9.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.1:*:*:*:*:*:*:* Versions 2.9.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.2:*:*:*:*:*:*:* Versions 2.9.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.3:*:*:*:*:*:*:* Versions 2.9.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.4:*:*:*:*:*:*:* Versions 2.9.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.5:*:*:*:*:*:*:* Versions 2.9.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.6:*:*:*:*:*:*:* Versions 2.9.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.0.0:*:*:*:*:*:*:* Versions 3.0.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.0.1:*:*:*:*:*:*:* Versions 3.0.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.0.2:*:*:*:*:*:*:* Versions 3.0.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.0.3:*:*:*:*:*:*:* Versions 3.0.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.0.4:*:*:*:*:*:*:* Versions 3.0.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.1.0:*:*:*:*:*:*:* Versions 3.1.0 Vulnerable ·Moodle
Remediation
- Fix · GHSA-c4cq-v4wp-28hg moodle/moodle (Packagist) Fixed in 3.1.1 Advisory →
- Fix · GHSA-c4cq-v4wp-28hg moodle/moodle (Packagist) Fixed in 3.0.5 Advisory →
- Fix · GHSA-c4cq-v4wp-28hg moodle/moodle (Packagist) Fixed in 2.9.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-5014
- 2026-10-03 Alias added: GHSA-c4cq-v4wp-28hg
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2016-5014 · CVE Program
- CVE-2016-5014 · NVD
- FIRST EPSS
- GHSA-c4cq-v4wp-28hg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences