Read the docs
TI-2016-05629 Aliases CVE-2016-6565GHSA-vhm5-wrvh-3x4h

Improper input validation in Imagely NextGen Gallery plugin

Priority LOW 38CWE-98Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
High
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-98.

Summary

The Imagely NextGen Gallery plugin for Wordpress prior to version 2.1.57 does not properly validate user input in the cssfile parameter of a HTTP POST request, which may allow an authenticated user to read arbitrary files from the server, or execute arbitrary code on the server in some circumstances (dependent on server configuration).

Why it matters now

EPSS 0.02506 84th percentileScored 2026-11-07
Fix Fixed NextGen Gallery plugin (Imagely): 2.1.57

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ImagelyNextGen Gallery plugin2.1.57 to before 2.1.572.1.57Patch availableCNA
  • NextGen Gallery plugin VendorImagely Affected 2.1.57 to before 2.1.57 Fixed in 2.1.57 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:imagely:nextgen_gallery:*:*:*:*:*:wordpress:*:*before 2.1.57VulnerableImagely
  • cpe:2.3:a:imagely:nextgen_gallery:*:*:*:*:*:wordpress:*:* Versions before 2.1.57 Vulnerable ·Imagely

Remediation

  • Fix · CNA NextGen Gallery plugin (Imagely) Fixed in 2.1.57

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-6565
  2. 2026-10-03 Alias added: GHSA-vhm5-wrvh-3x4h

References

Advisory 1

  • TI-2023-02956 NextGEN Gallery < 3.39 - Admin+ PHAR Deserialization CVSS 3.1HIGH 7.5
  • TI-2019-10666 A SQL injection vulnerability exists in the Imagely NextGEN Gallery plugin before 3.2.11… CVSS 3.0CRITICAL 9.8
  • TI-2023-02957 NextGEN Gallery < 3.39 - Admin+ Arbitrary File Read and Delete CVSS 3.1HIGH 7.2
  • TI-2024-05058 NextGEN Gallery < 3.59.3 - Admin+ Stored XSS CVSS 3.1MEDIUM 5.9
  • TI-2013-03217 NextGEN Gallery plugin before 1.9.13 for WordPress: ngggallery.php file upload CVSS 3.1CRITICAL 9.8
  • TI-2024-02901 WordPress Gallery Plugin – NextGEN Gallery <= 3.59 - Missing Authorization to Unauthenticated Information Disclosure CVSS 3.1MEDIUM 5.3
See all 26 →

Sources